ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

I know why I have no sound - I just can't fix it!!

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>

John DragoI know why I have no sound - I just can't fix it!!
by on Jan 8, 2012 at 3:04:52 am


I just built a new comp. The mother board has RealTek HD 5.1 sound built in (or pre-installed, whatever its called). I did a freash install of Windows 7 x64. fresh install of Adobe After Effects CS5.5 and I cant get sound to play in RAM preview.

I go into Edit> Preferences> Audio Hardware - within this window there is a "Default Device" with a drop down - the only choice I have in the drop down is "After Effects WDM Sound" - I do not get a choice for RealTek sound.

In this same window there is a button for "Settings" - in the settings are Input/Output tabs. Input has nothing. Output has "Enable Devices" . My choices are

Speakers (Realtek HD Audio)
Realtek Digital Output (Realtek HD Audio)
Realtek Digital Output (Optical) (Realtek HD Audio)

I have all 3 checked (just in case).

No sound during RAM preview. I'm 99% positive it's because I don't get the choice from the main "Audio Hardware" dropdown for Realtek HD Audio.

When I play the RAM preview, I can see the audio bars jumping up and down so I know After Effects sees the music - I just cant hear it. I am not a novice, and speakers work for everything else.

Any feedback would be greatly appreciated. Thank you.

PS: The file I am working with is an old file - not a newly created file from the newly installed AE. But I did test that by starting a new project with a new video and still - no sound.

Return to posts index

Butch GoldenRe: I know why I have no sound - I just can't fix it!!
by on Jan 8, 2012 at 4:10:20 am

I have an on-board Realtek sound card with no problem hearing sound in AE using the default WDM Sound. I did have though until I unchecked Digital Out to Optical (S/PDIF) because Realtek (at least on my user interface) only allows me one or the other - but not both. You'll find that in the settings for Digital Out in the Realtek interface. You also should choose 44.1 khz out as your default sampling rate.

Use only WDM Sound, make sure you can hear audio when using Media Player, then open a comp with audio and see if that buys you anything.

Return to posts index

John DragoRe: I know why I have no sound - I just can't fix it!!
by on Jan 8, 2012 at 4:50:51 am


Thanks a lot. I went into my Realtek interface and chose 44.1khz. I didn't have the same option with the Out to Optical in the Realtek interface - but I did uncheck the optical in AE - and bam - it works. Thanks for putting me on the right track.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved