ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Error: After Effects: Not enough memory to complete this encoding.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Vance
Error: After Effects: Not enough memory to complete this encoding.
on Nov 24, 2011 at 7:42:17 pm

I'm trying to render a video that I'm making in After Effects that is 1:45 long. However, I keep getting the error:

"After Effects: AEGP Plugin Media IO Plugin: MediaIO2 error 0x4 Not enough memory to complete this encoding."

I keep getting it after it has rendered only about 10 seconds of the entire project. I don't get how this could happen. I'm rendering it to an .mp4 file (H.264 format). I have multiprocessing turned off, I'm not sure if it will help if I turn it on since I do have 2 CPUs, but I also don't want my laptop burned to a crisp. All the files I was working with in the project are .M2TS files that are mostly time remapped with color correction.

Computer Specs:

Running Adobe After Effects CS4 (Fully Updated) on an Alienware M11xR2 Laptop

Intel(R) Core(TM) i3 CPU U 330 @ 1.20GHz

8.0 GB RAM (7.8 Usable)

Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit

Nvidia GeForce GT 335M 4.0 GB Video RAM

178.3 GB Free Disk Space.


Return to posts index

Michael Szalapski
Re: Error: After Effects: Not enough memory to complete this encoding.
on Nov 25, 2011 at 6:05:18 pm

No matter what version of After Effects you're using, you shouldn't encode your final compressed version from AE. Dave LaRonde explains why:
Dave's Stock Answer #3:

Don't use AE to compress files for final delivery. The various compressors are there only to make quick 'n dirty files showing a project's progress to producers, clients, the kids, etc. AE is incapable of doing multipass encoding, a crucial feature that greatly improves the image quality of H.264 and MPEG-type files in particular.

Render a high-quality file from AE, and use a different application to do the compression. Popular ones are Adobe Media Encoder, Sorenson Squeeze and Apple's Compressor, which comes bundled with Final Cut Suite. Even compressing in Quicktime Pro is better than compressing in AE...
Now, that's not your main problem. Your main problem is that CS4 and earlier versions of After Effects had problems with m2t footage and any other kind of long gop codec.
Again, we can turn to Dave LaRonde:
Dave's Stock Answer #1:

If the footage you imported into AE is any kind of the following -- footage in an HDV acquisition codec, MPEG1, MPEG2, mp4, m2t, H.261 or H.264 -- you need to convert it to a different codec.

These kinds of footage use temporal, or interframe compression. They have keyframes at regular intervals, containing complete frame information. However, the frames in between do NOT have complete information. Interframe codecs toss out duplicated information.

In order to maintain peak rendering efficiency, AE needs complete information for each and every frame. But because these kinds of footage contain only partial information, AE freaks out, resulting in a wide variety of problems.
Your solution would be to use the Adobe Media Encoder (or whatever) to convert your m2t files into uncompressed AVI or a Quicktime (with the PNG codec or some other lossless codec) and replace the footage in your AE comp with it. And then render a lossless file out of AE and use the Encoder again to make your final h.264. :)

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

jimmy wartson
Re: Error: After Effects: Not enough memory to complete this encoding.
on Feb 13, 2012 at 7:54:38 am

is there a way to render to MP4 FROM AE? i rendered it with format *quicktime movie* and its an .MOV now...


Return to posts index


Michael Szalapski
Re: Error: After Effects: Not enough memory to complete this encoding.
on Feb 13, 2012 at 2:13:41 pm

Yes. You just have to pick the right codec in your output settings.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]