ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

trapcode particular problem!

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
john damiani
trapcode particular problem!
on Nov 17, 2011 at 11:30:06 pm

i am following some tutorials on making a crowd, and i am running into a problem the tutorials dont cover.

i am using custom sprites, and in order to make light pass through the particles, i have to make the layer 3d, however, when i make the layer 3d, no matter what i do, i cant get the particles to come back! they are completely gone, i have search everywhere on the comp, check at different times during the comp, i even tried deleting everything but the sprite and the particular layer from the comp and the particles STILL wont show up! looking on the internet it seems that particular does not play nice when its on a 3d layer, but how am i going to get the light to shine through the particle? is there any other way to get light transmissions on this layer?

i would appreciate any help i could get! if anyone knows of a way i could get light to pass through these sprites i would be most grateful


Return to posts index

Roland R. Kahlenberg
Re: trapcode particular problem!
on Nov 18, 2011 at 1:28:51 am

You'll have to fake the lights or use Trapcode 2.0's Shading properties.

HTH
RoRK

Intensive AE & Mocha Training in Singapore and Malaysia
Adobe ACE/ACI (version 7) & Imagineer Systems Inc Approved Mocha Trainer


Return to posts index

john damiani
Re: trapcode particular problem!
on Nov 18, 2011 at 2:04:52 am

i have shading on, thats not the problem, the light is hitting the 2d objects just fine, however, its not allowing any light through the images, i dragged a light down to the bottom to show what i am talking about in this picture, as you can see no illumination happens on the objects between the light and the camera. i need to be able to get the light to go through the object

http://i87.photobucket.com/albums/k125/adecoy95/light.png


Return to posts index


Sam Smith
Re: trapcode particular problem!
on Nov 18, 2011 at 3:31:56 am

Roland is right. Use Particular 2, do not make the layer 3d, turn on shading, and move your light around.

-Sam


Return to posts index

Raza Ahmad
Re: trapcode particular problem!
on Nov 18, 2011 at 2:21:14 am

I'm going off memory here, but don't particular particles interact with lighting by defaults (as in, without the solid containing the effect being a 3d layer?)

http://www.redgiantsoftware.com/products/all/trapcode-particular/features/#...

The features list confirms this...


Return to posts index

john damiani
Re: trapcode particular problem!
on Nov 18, 2011 at 2:34:24 am

your right, it should, i am seeing some interaction with the lights, (the particles are being illuminated), but i cannot seem to be able to get the light to pass through them. 3d layers cause the particles to cease completely, so what your looking at is the particular solid on a 2d layer


Return to posts index


john damiani
Re: trapcode particular problem!
on Nov 18, 2011 at 2:50:21 pm

this is particular 2.0 btw


Return to posts index

Kevin Camp
Re: trapcode particular problem!
on Nov 18, 2011 at 3:02:32 pm

it sounds like you want the particles to cast shaddows, and i don't think particular will do that (i know v1.5 can't).

if that is what you are after, then you'll need to fake the shaddows.

you may be able to build the shaddows into the particles, but since you're light sources are point source, it may be hard to make that look correct (distant light sources may might be able to make this method believable).

a second particle system, same settigns, but with a custom particle that would be placed at the feet of the current custom particles might work. then you'd need to use an effect like fast radial blur (or shine) with the center placed near the light souce might give believable results.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

john damiani
Re: trapcode particular problem!
on Nov 18, 2011 at 3:07:24 pm

all i want is the light to pass through, under material settings its called "light transmission" but material settings only show up for 3d layers, so i cant get it for particular, is there any way to get it for particular? i dont need it to cast shadows on the floor or anything


Return to posts index


Kevin Camp
Re: trapcode particular problem!
on Nov 18, 2011 at 3:37:06 pm

so it sounds like you just don't need the particles to accept lights so you can see them regardless of their relationship to lighting...?

i don't have v2 so i don't know where the setting is for that, but i would assume that there is one.

if not, then you could put the particle system layer and custom particle layer in a precomp, that way it shouldn't respond to lighting.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

john damiani
Re: trapcode particular problem!
on Nov 18, 2011 at 3:53:06 pm

well, no i need it to respond to lights, but i want both sides of the sprite to be lit, currently only the side the light is shining on lights up, and the other side stays hard black, looking to let the light pass through to give me shine on both sides


Return to posts index

Kevin Camp
Re: trapcode particular problem!
on Nov 18, 2011 at 4:19:48 pm

if there aren't any ambient light settings within the effect, you could try using another light as a fill light, poisitioned near the camera.

if particular 2 can't respond to more than one light or the fill light doesn't work for the rest of the scene, then you might try duplicating the particle system layer and disabling the lighting for that system. then adjusting the opacity or blending modes to see if you can get the fill that you need.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]