ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Slow Audio Playback During RAM Preview

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Pravin Chottera
Slow Audio Playback During RAM Preview
on Oct 26, 2011 at 5:02:34 pm

So I just set up After Effects on a new iMac and totally forgot about all the optimizing I did on my old system. I unfortunately don't have that system anymore, so I can't just copy my settings.

Anyway, I opened an old project and dropped in a new voiceover and tried doing a RAM preview, and for some reason the audio sounds like it is slowed down. I think the over all speed of the playback is the same - meaning that I don't think it's playing at half speed - it's just that the audio sounds slowed down.

My comp is 29.97 and my RAM preview is set to AUTO.

Now when I click away from AE and RAM preview again, it sounds fine. Then if I stop the RAM preview, wait a second, and then RAM preview again, the audio is slowed down. I click away - RAM preview - it sounds fine - I wait - RAM preview - it sounds slowed down.

ARGH!

Thanks so much for your help everyone!


Return to posts index

Walter Soyka
Re: Slow Audio Playback During RAM Preview
on Oct 26, 2011 at 9:05:25 pm

What version of AE are you running? What kinds of footage?

Have you applied all the latest updates?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 26, 2011 at 9:11:27 pm

Hi Walter. Thanks for your response.

I'm on AE5.5. I don't have any footage - only animated images.

I haven't applied updates yet because I'm going to be switching over to the full CS tonight. Could the solution be as simple as applying updates?


Return to posts index


Walter Soyka
Re: Slow Audio Playback During RAM Preview
on Oct 26, 2011 at 9:14:28 pm

[Pravin Chottera] "I don't have any footage - only animated images."

Unless you're generating the audio with AE effects, you have footage (even if it's audio-only). What format is it? Have you tried transcoding it to another format?

Do you get any warning messages during RAM preview in the Info panel?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 26, 2011 at 9:21:56 pm

Ah, I see what you mean. My "footage" is an AIFF exported from Garage Band.

I have my RAM preview set to lopp, skip 1 frame, and play at half resolution. When I click RAM preview, my info panel says "fps: 14.985/14.985 (NOT realtime)" in red, even though it looks and sounds fine. Then when it loops, my info panel says "fps: 14.985 (realtime)" in white, even though the sound is clearly playing at half speed.


Return to posts index

Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 27, 2011 at 4:31:48 pm

Walter - I also tried converting my AIFF to m4a, mp3, and aac, all with the same result.

Any thoughts? Thanks again for your time and help!


Return to posts index


Michael Szalapski
Re: Slow Audio Playback During RAM Preview
on Oct 27, 2011 at 9:45:21 pm

Try transoding it as a WAV.
Also check what khz your sound file is. If that's off from what AE's expecting, it could cause weirdness.
Also check your Audio hardware settings in AE.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 27, 2011 at 10:39:43 pm

Great! I changed my audio output to "System Default" and it seemed to fix the problem. Thanks so much!

I don't remember it was originally set at, but any thoughts on why that change fixed the problem. Or why there was a problem in the first place?

Anyway, thank you Michael! And Walter!


Return to posts index

Michael Szalapski
Re: Slow Audio Playback During RAM Preview
on Oct 28, 2011 at 1:28:01 pm

I don't know the nitty gritty details, but if AE's trying to output audio to different type of audio setup, the signal it sends will be different.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 28, 2011 at 4:23:20 pm

Hey Michael - The problem is back. I don't know why/how it got fixed yesterday, but when I tried to RAM preview again today, the same thing happened.

It plays fine the first time, and then when it loops to play a second time, the audio is slowed down.

I tried using an AIFF, an AAC, and an mp3. They are all at ~44KHz.


Return to posts index

Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 28, 2011 at 4:36:49 pm

I checked my audio files, and they are all at 44.1 kHz.

I changed the audio sample rate in File>Project Settings to 44.1 kHz and it didn't help. The weird thing is that the RAM preview played correctly the first time. It is only slowed down when the preview loops.


Return to posts index

Michael Szalapski
Re: Slow Audio Playback During RAM Preview
on Oct 28, 2011 at 7:06:49 pm

That is weird.
Try transcoding them to WAV.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


Pravin Chottera
Re: Slow Audio Playback During RAM Preview
on Oct 28, 2011 at 8:41:50 pm

Very weird. I tried converting to WAV, but to no avail.

It turns out that what worked yesterday is changing my Audio Hardware and Audio Output Mapping in my Preferences to "Built-In Input/Built-In Output". That seemed to fix the problem, although half way through the day, the problem returned. When I went back into my Preferences to change it, I saw that it had somehow changed to "Built-In Output" and the "Built-In Input/Built-In Output" option had disappeared!!

After a few hours of grumbling I went back into my Preferences, saw that the "Built-In Input/Built-In Output" option had reappeared!!!!

I changed it to that and the problem seems to be fixed for now. I hope it lasts.

I'm going to do some fiddling around next week and may repost if I find out anything.

Thanks for your help Walter!


Return to posts index

Sean McCue
Re: Slow Audio Playback During RAM Preview
on Jul 18, 2012 at 8:49:31 pm

@Pravin - - I feel your pain. I'm currently experiencing the EXACT same thing. Running CS6. One slight variation in the symptoms, is that after changing my system preferences to "System Default Input/Output", it automatically switches back to "Built-in Output" when I go back to check on it. Bizzarre. Anyone have any other ideas for fixes on this issue?


Return to posts index

Vesmir oo1
Re: Slow Audio Playback During RAM Preview
on Dec 3, 2012 at 10:53:17 am

i guess you frame rate is not 'full res'. set it back to 25/whtever fps you use.
hope it works.


Return to posts index

Peter Hartman
Re: Slow Audio Playback During RAM Preview
on May 10, 2013 at 5:34:25 am

Just had the same problem. I closed GarageBand and restarted After Effects for the win. Close any audio programs and try your RAM preview again. You may need to restart AE. I tried everything but nothing worked except this. Hope this helps!

Peter Hartman


Return to posts index

Greg Wall
Re: Slow Audio Playback During RAM Preview
on Aug 9, 2013 at 2:38:58 am

I have been experiencing the same thing tonight. Bought I still had Logic PRO running in the background. Once shut that done and went back to AE, the first playing of the RAM Preview played fast. Then the rest have been correct. So I believe you are right about another program accessing the audio processor. Once AE is the sole controller the audio plays fine.

Thanks to Creative Cow and all of you who contribute here. Without this thread I'm sure I would be pulling what's left of my hair out in the next hour or so.


Return to posts index

Carlo Inzunza
Re: Slow Audio Playback During RAM Preview
on Aug 8, 2014 at 9:54:43 pm

SUCCESS!!! I was experiencing the same problem, and I got it resolved, I watched a youtube video of a guy saying that you needed to match your Frame Rate in the composition settings to your RAM preview's frame rate, but that didn't work. what worked like a charm was, I had garage band open still, I closed that and the problem got fixed right away! HA! who would have thought! thanks


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]