ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Changing Mask Opacity to fade in part of object that is masked out is not working..??

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Hemma KranskyChanging Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 2, 2011 at 2:36:53 am

Hi,

I have looked everywhere on the internet for the answer to this & figure that could be only for two reasons;

1. Noone else has had this problem/ has tried to do similar thing
or
2. It's so plain, simple and obvious.

None-the-less..

I am trying to simply fade in the part of the image that has been masked out (right hand side of the ladies face, below). However, when I put in two key frames of the opacity going from 100%- 0% etc etc it only effects the left hand side of the ladies face that hasn't been masked out. I have tried doing the opposite and creating a new mask and selecting "intersect" (as "add" doesn't seem to affect it at all for some reason..?) but again it only effects that same part of the face that I don't want changed.



I would so appreciate any help! Thank You!

Hemma


Return to posts index


Angelo LorenzoRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 2, 2011 at 4:46:27 am

It's counter intuitive as to how this works. The mask opacity affects what is inside the mask... sometimes. It seems like setting the mask to "subtract" lets the opacity affect what is outside the mask, much like selecting "invert" in "add" mode. Dumb.

There is a work around:
1. Create a shape layer, any color.
2. ctrl-x (cut) your mask from your current layer and paste it on the shape layer (make sure the mask is in "add" mode).
3. Switch this new layer's mode to silhouette alpha. That layer's mask opacity setting should now work exactly as you like, fading in more detail into the masked area when set to 0%

Note: If you get some weird behavior like it punching through your entire comp, you may need to pre-comp this layer pair.

- Angelo Lorenzo
- http://FilmsFor.Us Sell your film and connect with your audience


Return to posts index

Hemma KranskyRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 2, 2011 at 9:20:15 am

Great! That worked if I created it as a pre-comp as I have lots of layers & a colour burn already applied to this layer of the lady. But the only problem is that the mask has to move/ animate in this sequence. And applying this technique straight into the comp (without a pre-comp) created what you can see here:



Because it has the blend mode set to "silhouette alpha" there was no way of adding "colour burn" also.

If there's no solution to this then I could just keep flicking between the pre-comp and the comp & try to get the movement of the mask to match up to that of the main composition & import into main comp... That idea is incredibly unappealing.

Hemma


Return to posts index


Angelo LorenzoRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 2, 2011 at 10:04:49 pm

What is your animation like? Alternately, if it's two faces meeting or coming out of that center post why dont you have:

background layer masked for the center post
normal face 1
normal face 2
fill background

Perhaps if you describe what is happening in terms of how things are moving, there may be a better alternate for this altogether.

- Angelo Lorenzo
- http://FilmsFor.Us Sell your film and connect with your audience


Return to posts index

Pentti KakkoriRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 2, 2011 at 6:15:32 pm

Add a new (add)mask that covers your whole frame and put it above your current mask. Now your old mask's subtract opacity keyframes should work.


Return to posts index

Hemma KranskyRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Oct 14, 2011 at 12:31:54 am

GREAT!! Adding the extra mask on top of the other worked like magic! I don't know why but I'm happy to just move passed that block & maybe another time work out why that solved everything.

Thanks Angelo & Pentti!!

Hopefully this will also help other people with the same problem too.

Hemma


Return to posts index


doland ruizRe: Changing Mask Opacity to fade in part of object that is masked out is not working..??
by on Jan 16, 2014 at 7:14:05 pm

Wow. Same exact problem. Learned something I will now use constantly. Thanks!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]