ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Settings Seem Right; but I must be wrong Shadows

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Greg Knollmeyer
Settings Seem Right; but I must be wrong Shadows
on Sep 23, 2011 at 2:34:40 pm

I have done a simple comp in AE with a precomped vid/text layer set at 90 degrees from a shape and two lights. All of the settings seem (to me) to be correct about accepting shadows and positioning. Yet, I don't get a those clear shadows from the text like I'd like. I'd like the outlines of the text to fall in shadow clearly on my blue shape. Here's two images of the comp, view & settings for layers. Any help would be appreciated.

BTW I'm working in CS4 on MacBook Pro, 2.66 GHz Intel Cor i7, 8 GB RAM, OS X 10.7.1

<a href="http://i1.creativecow.net/u/134996/noshadow2.jpg"><img src="//i1.creativecow.net/u/134996/noshadow2.jpg" border="0" /></a>
<a href="http://i1.creativecow.net/u/134996/noshadow1.jpg"><img src="//i1.creativecow.net/u/134996/noshadow1.jpg" border="0" /></a>


Return to posts index

Kevin Camp
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 23, 2011 at 4:14:42 pm

first try disabling opengl for previews just to make sure that's not the problem. you can do that in ae's preview preference, or from the preview settings menu found by clicking the lightning bold icon at the bottom of the preview window.

if that's not it, then try moving your light to different angles to see if you can start seeing shadows somewhere... or potentially add a new 3d solid directly behind the text to see if you can get a shaddow on that. then troubleshoot from that point.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

John Cuevas
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 23, 2011 at 5:31:41 pm

In the timeline window there is also a Draft 3D button that when enabled will turn off shadows.

Johnny Cuevas, Editor


Return to posts index


Roland R. Kahlenberg
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 23, 2011 at 6:35:06 pm

It looks like your Light Intensity is way too high. This parameter affects the visibility of shadows.

Of course, the other possibilities already highlighted deserve a look.

Cheers
RoRK

Intensive AE & Mocha Training in Asia.


Return to posts index

Greg Knollmeyer
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 24, 2011 at 12:48:46 pm

Thanks to all for your suggestions. I am still looking for a solution

--I disabled openGL and saw no changes. I toggled it a few times during problem solving but saw no difference.
--I moved the light and objects around a bit and couldn't find any shadows. I also added two other simple solids, a non-comped text solid & a rectangle (pictured below); but still can't come up with any shadows.
--I toggled draft 3d, but that hadn't been on.
--I also lowered the light intensity and played with settings between 80 & 150. I know it is high; but I thought more contrast might have come from more light.

So I remain confused about this one. I did up a new comp with what I think are the same settings and I get shadows on basic rectangles. Odd. Any other ideas.

<a href="http://i1.creativecow.net/u/134996/water3.jpg"><img src="//i1.creativecow.net/u/134996/water3.jpg" border="0" /></a>


<a href="http://i1.creativecow.net/u/134996/shadow.jpg"><img src="//i1.creativecow.net/u/134996/shadow.jpg" border="0" /></a>


Return to posts index

Roland R. Kahlenberg
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 24, 2011 at 3:13:20 pm

Why not post the AEP over here on the COW and let someone take a good look at it.

Cheers
RoRK

Intensive AE & Mocha Training in Asia.


Return to posts index


Greg Knollmeyer
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 24, 2011 at 8:52:30 pm

That is a kind offer. If anyone has time/interest you can download the file at http://gregknollmeyer.com/files/ShadowNoShadow.zip. The archive has the aep plus a free clip that I was using within the water text. So it is 128 mb.

The project has a comp where shadows work fine, the precomped water text, and the problem comp. There's nothing much going on in either of these, I was just beginning to set the stage when I ran into an issue.

Thanks


Return to posts index

Roland R. Kahlenberg
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 25, 2011 at 8:58:41 am

Firstly, do not include stock footage that you do not own into any of your AEPs that are made available to the general public. WHen we purchase a stock footage or download any that is free, we are only licensed to used it, not to distribute it.

Secondly, you have used Layers Styles in your 3D layers. This wasn't obvious in the images you posted. Yet, it is the cause of your shadows not appearing.

Layer Styles, in AE, inhibit 3D interaction between layers. 3D interaction is defined as -
1) the casting of shadows, where Layer A casts shadows onto Layer B
2) accepting shadows, where Layer B accepts shadows casts from Layer A
3) intersection of 3D layers, where Layer A intersects into Layer B

Should any of your 3D layers, say, Layers A and B contain a Layer Style, then no 3D interaction is possible.

Further, even if Layers A and B do not have Layer Styles applied BUT you place a 3D layer, Layer C (which contains a Layer Style), between Layers A and B IN THE TIMELINE, then Layer C will inhibit 3D interaction between layers A and B.

In other words, any shadows that you saw, due to the 3D interaction between Layers A and B, will be removed as soon as you introduce Layer C.

The workaround is to remove the Layer Styles OR precompose the layer with the Layer Style. Then, in the resulting nesting composition that is created, enable its 3D and Cast Shadow options. Should you go with the precompose route, ensure that you do not switch on Collapse Transformations for the nested composition as this will essentially 'transport' the Layer Styles from the precomposition, into the current composition.

HTH
RoRK

Intensive AE & Mocha Training in Asia.


Return to posts index

Greg Knollmeyer
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 25, 2011 at 4:10:33 pm

Thanks for the help. I didn't know layer styles caused that sort of interaction. I pulled down the file as well. Obviously you're right about the clip.


Return to posts index


Roland R. Kahlenberg
Re: Settings Seem Right; but I must be wrong Shadows
on Sep 26, 2011 at 4:30:59 pm

No worries Greg. We all Live and Learn - that's what it's all about.

Cheers
RoRK

Intensive AE & Mocha Training in Asia.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]