ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

10-bit highlight clipping problem

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Scott McDonnell10-bit highlight clipping problem
by on Sep 14, 2011 at 1:22:41 pm


I am working for the first time with 10-bit DNxHD QuickTime footage in AFX CS5 on Windows and have encountered a few issues.

We wish to import DNxHD, add effects, and export as the same 1080p/25 DNxHD 185 10-bit.

I thought the workflow with 10-bit is to set the project settings Color Depth to 16 or 32 bpc but both give me a clipping in the whites:

If I turn to 8bpc the highlights appear normal:

but does this not render the output as 8-bit?

I have tried various color management options and all interpret footage options and none fix the issue. Any ideas?

Here are the rest of the settings:

Return to posts index

ben g ungurenRe: 10-bit highlight clipping problem
by on Sep 14, 2011 at 9:41:42 pm

If you hover your mouse over the problematic colors and look at your info window, I bet you'll see "nan" instead of a number. This is a mathematical issue, where "nan" stands for "Not a Number." It's something that pops up every once in a while when you're working in spaces higher than 8-bit.

Fortunately Brendan at fnord software has written a plugin that will catch any NaN pixels and convert them into something readable (thank you Brendan!).

good luck!

Ben Unguren
Motion Graphics & Editing

Return to posts index

Scott McDonnellRe: 10-bit highlight clipping problem
by on Sep 15, 2011 at 2:50:02 pm

Thanks for the help and good suggestion.

Just checking the info and the black pixels show up as a color:

Here is a black pixel in 32bit mode:

And this is 16bit:

Arrgh - it looks fine in QuickTime and Premiere.

Return to posts index

Jakob WiessnerRe: 10-bit highlight clipping problem
by on Dec 21, 2011 at 8:52:39 pm

Hi Scott!
I'm having the same issue here... did you manage to find a solution yet?
Best, Jakob

Return to posts index

leif falkRe: 10-bit highlight clipping problem
by on Dec 31, 2011 at 6:04:18 pm

I would also be happy if someone solved the problem and shares his knowledge..
i donĀ“t like everything related to avid..

Return to posts index

Scott McDonnellRe: 10-bit highlight clipping problem
by on Jan 4, 2012 at 9:35:42 am

Hi, sorry to not posted earlier but we worked around in the end rather than solved it.

The problem seemed to be in footage supplied by the post house and not in any we rendered in-house. To work around we dropped the AFX down to 8bpc essentially rendering 8-bit. I would recommend looking at the source and trying different outputs or taking the hit on 8-bit.

Return to posts index

Alex JohnsonRe: 10-bit highlight clipping problem
by on Jun 17, 2012 at 10:43:24 pm

Unfortunately that's the exact same thing we've had to do as well. I can't seem to find any answer to this issue on the net. If I figure something out I'll post the solution here, as I'm sure all of you will.

Here's hoping we don't smash too many monitors before the answer arrives...

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved