ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

depth of field in CS5

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jose Fernandez
depth of field in CS5
on Aug 19, 2011 at 7:10:29 pm

Hello this is my first post I want to thank you all beforehand for the support provided in this forum, I have situation that I need the foreground object in focus and the rear object out of focus, easy, but need a background object isolated to always be in focus, is that possible?


Return to posts index

Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 19, 2011 at 8:17:20 pm

Are you talking about a camera focus/out of focus simulated with a blur and masking on footage, or in a 3d comp in AE, working with the AE camera?

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Jose Fernandez
Re: depth of field in CS5
on Aug 19, 2011 at 8:59:14 pm

A 3d comp in AE, working with the AE camera, I want to keep the background always in focus since its a wall and floor simulation not 2 separate planes


Return to posts index


Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 20, 2011 at 8:10:19 pm

So you want a foreground object in focus, then an object behind out of focus and then the background in focus again? Maybe I did not understand your issue, but this seems a bit odd. Could you post a still of what you're trying to achieve?

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Jose Fernandez
Re: depth of field in CS5
on Aug 20, 2011 at 8:18:35 pm

imagine a 2d image that shows the floor and the wall now when i place three objects in a carouselwith depth of field ON the objects close to the camera aer in focus as they spin the objects towrds the back are blured, well since the 2d image is in the back its always blurred, i want that image alone not to be blurred while everything else works as it should, the blur on the image I will fake in photoshop since it never moves, hope you understand, basically have one object not affected by the camra depth of field regardless of its position.


Return to posts index

Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 21, 2011 at 12:04:31 pm

Since you want the 2d background not to move or be affected by the depth of field, you should use that as a 2d layer only and not a 3d layer. This way it will not be affected by the camera dof.

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index


Jose Fernandez
Re: depth of field in CS5
on Aug 21, 2011 at 3:25:41 pm

I tried that but I can't control the backdrop to be in the right position the only solution would be to somehow keep it from bluring. Any other ideas?


Return to posts index

Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 21, 2011 at 6:40:34 pm

Create a separate comp for the backdrop, with the same type of camera, but without depth of field enabled. Link the controls for this camera with the controls from the camera from the main comp ( if you use a camera rig you should create the same rig in the background comp and link all controls to those in the main comp). Bring the background comp in the main comp and leave it as a 2d layer.

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Jose Fernandez
Re: depth of field in CS5
on Aug 21, 2011 at 7:21:46 pm

Genius!!!! Thank you for your following up and understanding my bad explanations thank you very very much it works perfectly!


Return to posts index


Jose Fernandez
Re: depth of field in CS5
on Aug 21, 2011 at 7:38:12 pm

I just realized my light don't work, will they ony work in 3D space?


Return to posts index

Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 21, 2011 at 7:53:10 pm

Yes, lights will only work in 3d space.
There's a solution for that as well.
Create the main comp with the background as a 3d layer, with lights and all.
Duplicate the comp- we call this one now background comp (BKcomp).
Link the camera inside this one with the cam in the main.
Make sure Depth of Field is disabled in BKcomp.
In BKcomp go into the "Material Options" of all your layers (except the background plate) and on the "Cast Shadows" property right click to change from "On" to "Only". This way you get all the shadows cast on the background.
Use BKcomp as a 2d layer in Main comp.

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Jose Fernandez
Re: depth of field in CS5
on Aug 21, 2011 at 8:26:10 pm

Thanks again Ted, what I did is copy and paste all the lights to comp2 and everything worked perfectly. Thank you very much I couldn't have done it without you.


Return to posts index


Tudor "Ted" Jelescu
Re: depth of field in CS5
on Aug 21, 2011 at 8:54:11 pm

Hey, glad to be of assistance!

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]