ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Keylight Premultiplying Issue

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Brian MonroeKeylight Premultiplying Issue
by on Aug 15, 2011 at 10:26:23 pm

Hey guys,

I'm sure this issue has been covered in various ways but I was wondering if someone could help me out. I'm using Keylight on a person shot against green screen and I was able to get some decent settings but I'm finding that the final result doesn't carry all the way up to other compositions that include the Keylight composition. I precomped the keylight footage so I can add additional adjustment layers and color correction and have all of that precomped to be integrated with other keylit actors in a cg environment. For some reason though, the person with Keylight gets a black outline (as if the "unpremultiply result", is disabled) in the very top comp. It looks fine in the Keylight precomp but if I paste that footage in any other composition or view it in the top composition, the Keylight edge looks sharp and not as clean as it was in the Keylight comp. So far I've been shrinking the screen matte down to compensate for the added black outline in the top composition but i'd like to at least find out why it's creating that outline in the final composition and not in the Keylight precomp.

I appreciate any help and hopefully this wasn't too confusing! Thanks


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved