ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Another 3D Cube Problem~

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ferdian FeisalAnother 3D Cube Problem~
by on Jun 18, 2011 at 6:57:31 am

Hello! I'm new in After Effects :) and this is my 1st post.
I have a problem with my cube. I'm making a 3D cube in AE, it has another small cube inside it. But when i try to moving the camera, the small cube inside is come into sight through the bigger cube. Its like the bigger cube transparency is not 100%. Sorry for my bad explanation, but you can see the picture to figure it out what i mean..

Return to posts index

Tudor "Ted" JelescuRe: Another 3D Cube Problem~
by on Jun 18, 2011 at 1:40:58 pm

Without seeing all your comps and precomps I can't say for sure, but either you have a 2d layer in between 3d layers, or the position of the layer forming the cubes is not really as it seems and some layers from the small cube may actually touch the layers of the big cube in 3d space. Instead of precomping the layers for the cubes, I would link them to a Null, name the null for the cube (small cube and big cube) and then hide them so that you'll only get the null layers in the comp. This way you can position and troubleshoot all in one comp instead of trying to fix things in 3 comps.

Tudor "Ted" Jelescu
Senior VFX Artist

Return to posts index

Ferdian FeisalRe: Another 3D Cube Problem~
by on Jun 19, 2011 at 9:25:14 am

Thx for ur response :)! I've made sure that all the layers in small cube didn't touch the big cube in that comp :(.. My big cube is 300x300px, and the small cube 250x250px. I want to make a 'gap' between the cube, so the final cube has a 25px 'thickness'. Here it is all of my comp:

My first problem is the edge of the layers on the cube has a little gap, i search in this forum and found the same problem with me. So, i try the 'alpha add' thing, but nothing happen :(.. So i try different solution, i duplicate all the layers (on each cube) and move it 1px away from the previous layer. The result is like this:

But with or without duplicating layers on each cube (i mean ignore my first problem), i'm still have a problem that i'd explain on my 1st post :(..

Return to posts index

Tom GilbertRe: Another 3D Cube Problem~
by on Apr 26, 2016 at 9:57:58 pm
Last Edited By Tom Gilbert on Apr 26, 2016 at 10:01:44 pm


I am doing short video, but encountered problem related to motion path. I have a composition in 3D space where camera and 3D cube are moving. Everything is ok, but I want to apply a motion blur effect on cube when it spins. Cube consists of 6 nested layers: back, left,..., front. (see image below).

These layers are parented to null object, which controls all the movement of cube.
So, to apply blur effect only on cube, I had to precomp all these 6 layers and add adjustment layer with blur effect inside that comp. After that, the cube doesn't move along null object's path anymore. It just moves somewhere around camera and rarely appears into frame.
Maybe someone could give me an advice on how could I fix it?

Thank you

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved