ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Increasing Render times

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Alexander Papadopoulos
Increasing Render times
on Jun 4, 2011 at 4:07:21 pm

Hi all
I ve been working on a project that involves using the same 30 sec movie file and changing the text that appears. In the end I might have around 60 more or less files that I would like to batch render. However When I try to do that on my mac book pro i find that the Rendering files take longer and longer to finish. It basically is the same file so the time should remain the same but after each render I have to add 30 seconds. Is this common? It looks like some kind of memory issue.
Any ideas? Any help on systems settings would be much appreciated!

My system is a 2.2 intel i7 with 4 gb Ram and running Mac OS X 10.6.7
Chhers


Return to posts index

Steve Modica
Re: Increasing Render times
on Jun 5, 2011 at 2:57:07 am

When you fire it up and it starts running, look at system activity reporter and see what kind of throughput you're getting. Check again the next time and compare. If it's not slower, than there must be more work to do for some reason.

Steve Modica
CTO, Small Tree Communications


Return to posts index

Alexander Papadopoulos
Re: Increasing Render times
on Jun 5, 2011 at 1:01:16 pm

I dont think that it has more work to do. When the same work is done on a pc the time remains constant! Its after fx on the mac causing the trouble!. It seam to accumulate each render time. Even if I stop the render and start over it will pick of from the last render time. The only way I found so far is to close the application and restart it. But that doesn't work for me if I have to do that 60 times :-(


Return to posts index


Lukas Thorsson
Re: Increasing Render times
on Jun 6, 2011 at 8:15:52 am

Seems to be a cache / RAM Problem. Have you tried the "secret" settings for flushing cache?

I don't know things go on mac exactly, but on windows you got the possibility to do exactly what you want: You can start After FX from the shell telling him which file to render. With the option -rqindex you can specify which item in the queue you want to render.
For rendering item 1 in queue command is:

aerender -project file.aep -rqindex 1

I'd put that line in a batch file, doubling it 60 times and increase the index on each line.

On the PC the program is called aerender, maybe someones who's more involved into mac stuff can get you more details.


Return to posts index

Walter Soyka
Re: Increasing Render times
on Jun 7, 2011 at 3:14:40 pm

[Lukas Thorsson] "aerender -project file.aep -rqindex 1

I'd put that line in a batch file, doubling it 60 times and increase the index on each line.

On the PC the program is called aerender, maybe someones who's more involved into mac stuff can get you more details."



This would work on the Mac as well. Here's Adobe's documentation for aerender [link].

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Steve Modica
Re: Increasing Render times
on Jun 7, 2011 at 4:50:34 pm

[Alexander Papadopoulos] "I dont think that it has more work to do. When the same work is done on a pc the time remains constant! Its after fx on the mac causing the trouble!. It seam to accumulate each render time. Even if I stop the render and start over it will pick of from the last render time. The only way I found so far is to close the application and restart it. But that doesn't work for me if I have to do that 60 times :-(


Posts Index"


Have you tried bringing up activity monitor and looking at a memory map of the process? You might find that it's growing in memory and perhaps it's running up against some limits. You could compare before and after and see what's growing. (the purge cache idea sounds good to me)

Steve Modica
CTO, Small Tree Communications


Return to posts index


Christian Reid
Re: Increasing Render times
on May 7, 2013 at 3:07:21 pm

I've been having the same problem and came here to search for a solution. Obviously didn't find it!

I have 65 comps of 5 seconds each. If I render only one at a time, it takes about 1 minute to render.
When I try to render multiple, the first one takes 1 minute, second takes 1:40, third 2:10 and so on.

It doesn't make any sense to me, but what I'm doing right now is stoping the rendering on the 5th item in the queue, deleting the past 4 grayed-out (completed) renders and starting the 5th again.

That way I can keep acceptable render times, but I have to be constantly looking at my screen.

Really sucks! Wish I could get it solved!

I've tried using CS5, CS5.5 and CS6...same problem all around!!


Return to posts index

Walter Soyka
Re: Increasing Render times
on Jun 6, 2011 at 1:18:45 pm

This does sound like a memory issue -- and 4 GB is not very much RAM at all for After Effects.

Do you have multiprocessing enabled? If so, turn it off.

What version of AE are you using? Have you installed the latest updates for it?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Alexander Papadopoulos
Re: Increasing Render times
on Jun 6, 2011 at 5:00:37 pm

Hi guys.
On the pc it works fine. No problems, I'm working with cs4, and althought i know that 4 gbs aren't enough you have to keep in mind that it basically a 20 sec pre rendered quick time movie as a backdrop and I just add some text over that. It should be able to run easy. A friend of mine that has a mac book pro has the same problem. I think it could have something to do with the operating system!
Ps I'm also new to mac as I only have it for a week


Return to posts index


Walter Soyka
Re: Increasing Render times
on Jun 6, 2011 at 5:22:04 pm

On CS4, go into Preferences > Memory and Multiprocessing, and adjust the slider towards Faster Rendering. Make sure "Render multiple frames simultaneously" is not checked.

Does that help?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Lukas Thorsson
Re: Increasing Render times
on Jun 7, 2011 at 10:10:49 am

Try out purging cache after each 50 frames rendered. Or 25, or 10... Each purge will slow down the rendering a bit, as AE needs to reload all footage, but it may help.

You'll reach these secret setting if you hold down shift while entering the a random tab of the preferences menu. Once the windows shows up, you'll find a "Secret" Tab on the buttom of the list.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]