ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Losing alpha...

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ed Gilbert
Losing alpha...
on May 25, 2011 at 5:10:22 pm

OK... I might be a complete idiot... but...
I've got a comp as seen below. The Particle layer is a solid with Particular 2.0 on it. This layer is set to Screen under Mode so it will look like the particles are being sucked down a wormhole.

Everything looks like I want it... but when I render this comp it will NOT render the alpha. Yes, I'm setting it for RGB+Alpha in the render settings. I've tried dozens of renders trying to get the background to be transparent like it should... but each time the black background ends up being black instead of transparent.

What am I doing wrong? Is it the Screen Mode on the Particle layer?

FYI... the WormholeMeshPreComp.mov layer is the wormhole mesh thing. It's background is alpha'd properly.

Any help would be greatly appreciated!
ED



Return to posts index

Joey Foreman
Re: Losing alpha...
on May 25, 2011 at 5:23:55 pm

What codec are you rendering to?

Joey Foreman
Editor/Compositor/VFX Artist


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 5:31:04 pm

All of them!!!! Just kidding...
I've tried
Quicktime - PNG - RGB+Alpha
Quicktime - JPG - RGB+Alpha
Quicktime - Animation - RGB+Alpha
Video for Windows = No Compression - RGB+Alpha

All of those have worked fine in the past for intermediate files. I'm goin' nuts!

BTW... I'm using CS4 & Particular 2.0


Return to posts index


Brian Charles
Re: Losing alpha...
on May 25, 2011 at 5:38:34 pm

What do you see when you click the transparency grid switch in the Comp panel?



Return to posts index

Dave LaRonde
Re: Losing alpha...
on May 25, 2011 at 5:43:54 pm

I can't tell from the window grabs: have you confirmed that you actually HAVE transparency in your comp?

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 5:41:01 pm

Yeah... I was using the solid in the last layer. I would unhide it to see that the background was transparent.


Return to posts index


Joey Foreman
Re: Losing alpha...
on May 25, 2011 at 5:40:43 pm

Before rendering, have you checked that your comp indeed has transparency by clicking on the checkerboard, or by setting the comp display to Alpha?

Joey Foreman
Editor/Compositor/VFX Artist


Return to posts index

Darby Edelen
Re: Losing alpha...
on May 25, 2011 at 5:38:33 pm

You should check to confirm the alpha of the composition by hitting alt-4 within AE. I'm not sure how you're setting up your particle layer but it could be a problem there, check under the Render properties group (i believe that's the name) of the effect.

Are you checking your rendered footage in AE or in a video player?

Darby Edelen


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 5:38:38 pm

I was originally using this comp(Wormhole) in another comp. It was showing up with the black background in there unless is checked the Collapse Transformations on the Wormhole comp layer. Then it would have transparency. But, when I would try to render that comp or pull that comp into another comp the black background is back on the wormhole layer. That is why I decided to try to render the Wormhole so I could avoid whatever weirdness is going on.


Return to posts index


Darby Edelen
Re: Losing alpha...
on May 25, 2011 at 5:39:56 pm

[Ed Gilbert] "It was showing up with the black background in there unless is checked the Collapse Transformations on the Wormhole comp layer."

It sounds like your wormhole layer may not actually have an alpha but is instead using blending modes to look like it does. You may need to use a Channel > Set Matte or Luma Track Matte to give it an alpha.

Darby Edelen


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 5:46:55 pm

Hmmmm....
OK... I checked for the alpha using the "Toggle Transparency Grid" and apparently I don't have a transparency on the Particle layer.

That layer is a solid with Particular 2.0 on it. I checked the Render settings in Particular... it's set to normal. So, shouldn't I be getting an alpha'd background after dropping Particular on a solid? Or am I missing something fundamental here?

I really appreciate the help everyone!


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 6:05:02 pm

Thank you guys! I figured it out... after being schooled a little.. ;)

It was the Render>Transfer Mode setting in Particular. I had set it BACK to Normal. I thought that was the default. By default it is None... And of course when I set it back to None... I have transparency.

And that kids... is why you shouldn't smoke crack while using After Effects.

Thanks again!


Return to posts index


Darby Edelen
Re: Losing alpha...
on May 25, 2011 at 6:04:43 pm

I'm away from my computer right now, but I think there should be a 'none' mode

Darby Edelen


Return to posts index

Ed Gilbert
Re: Losing alpha...
on May 25, 2011 at 6:10:40 pm

Thanks Darby...
I figured it out a little bit ago... It was indeed the None mode that was the culprit. I posted a thank to close this out,but used the word c r a c k in it and it got flagged for review. So, I'm sure it will show up eventually. But, thanks!!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]