ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

GetDepthPinFlags, AESend failed, and MCExportInfo::Destruct

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andy SappGetDepthPinFlags, AESend failed, and MCExportInfo::Destruct
by on May 16, 2011 at 9:47:34 pm

I have run into some big issues with a huge project I am working on with a looming deadline, and am unable to render this animation.

Project/render specs:
I am trying to render an 8-bit Quicktime, Animation codec, and the canvas size is 2760x1920. (I have rendered MANY pieces of this project at this canvas size without issue up to this point)

Computer Specs:
AE CS5, OSX 10.6.7 with 2x2.66 Ghz 6-Core Intel Xeon with 24GB of RAM.

This project has many iff sequences rendered out of Maya, but all have been pre-rendered to Quicktime files with alpha.

Here are the error messages:
I get this one the most, and as per Mylenium's forum post on VCP, the only lead I have on this is that it could be an "invalid/ incompatible channel mapping or bit-depth conversion issue"... however I am not sure exactly what this means, or how to solve this problem.
<140735084698784> GetDepthPinFlags> 5> 3: 32 bit.

This is next in order of frequency occurred. I have read that in most cases this problem vanished in CS5, but it has not for me. It happens both when I try to use BGRenderer, and when I just use the AE GUI to render.
aerender ERROR -609: AESend failed to send apple event at line 766

Running out of ideas, I tried rendering as a 32-bit TGA sequence, and wound up with:
MCExportInfo::Destruct 5 Destruct for 6115375232

I have tried rendering on three different machines (all OSX), yielding the same results from all three.

I am out of ideas on how to solve this and am in serious need of some assistance!

Return to posts index

Andy SappRe: GetDepthPinFlags, AESend failed, and MCExportInfo::Destruct
by on May 19, 2011 at 3:00:51 pm

Just an update on more error messages I have been getting.
<140735084698784> <DynamicLink> <5> /Library/Application Support/Adobe/Common/dynamiclink/CS5/

<140735084698784> <UnconstrainFPSIfAppropriate> <5> Setting ABDEVideoFPS constraint off.

I seem to have isolated my trouble down to a set of animated masks I created to roto out a series of objects on the main color pass of a 3D render out of Maya. Why a set of masks would flag so many errors and cause so much trouble is beyond me... but for the time-being - deleting those masks has solved the problem.

Return to posts index

Gareth TredreaRe: GetDepthPinFlags, AESend failed, and MCExportInfo::Destruct
by on Jun 30, 2011 at 8:51:26 pm

I have the same issue, except i am working in 32bit, on a PC and i cant delete those masks. Did you figure anything else out?

Return to posts index

Andy SappRe: GetDepthPinFlags, AESend failed, and MCExportInfo::Destruct
by on Jul 1, 2011 at 2:48:34 pm

I want to say that after I deleted them, I either re-created them, or got some RGB passes from Maya to block out what I had originally masked.

I hope that helps!

Return to posts index

Tom WatsonRe: GetDepthPinFlags, AESend failed, and MCExportInfo::Destruct
by on Jan 11, 2013 at 10:29:02 am

MCExportInfo::Destruct 5:

I have been writing and extendScript tool for AE and was getting this message. The problem appeared to be in setting the file location object (for a renderQueue Item) as a temporary variable that I was re-using in a loop. The answer in this case was to create an array of file objects in the loop.

My assumption here was that while my (ECMA) script could handle that, it is interacting with the OS and Graphics card which won't support object mutability.

Although your error is likely from a different root cause, I suspect my solution will be helpful anyway :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved