ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

PLEASE ADVISE ASAP! After Effects will not render SOME assets.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Feldmann
PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 6:47:56 pm

Hello,
I am under a very tight deadline and of course NOW is the time when After Effects is giving me trouble (isn't that always the way?).


Does anyone have any idea why After Effects might just decide to not render SOME of my assets? I have two layers that have assets (one is an Illustrator file, the other a large photoshop file) that will show up in the viewer, it even shows up in a RAM preview.. But when i go to render it doesn't render as if the transparency was set to zero (though it's not)- you can see the background, but the assets don't render. The layers are neither set as a guide layer nor are there any errors.

Thank you very much for your time and assistance,
Chris


Return to posts index

Dave Johnson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 7:21:06 pm

Hmmm ... seen lots of AE issues, but that one is a first ... some things to try ...

Make sure you have the latest updates installed for each of your Adobe software versions.

Purge all of AE's cache from the file menu.

Duplicate the AI & PSD files, open the duplicates and re-save them without changing anything, then try another test render.

If you have a backup of the AE project, try a test render from it.

If not, shame on you and make one now ... then, import the project file into a new project and try another test render.

Sounds like it might be a file corruption issue with either the AE project file or the sources ... any crashes, etc. lately?


Return to posts index

Dave Johnson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 7:26:46 pm

By the way, more info would be helpful ... platform, AE version, sources on local drive or networked, etc, etc?


Return to posts index


Chris Feldmann
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 7:47:20 pm

Sure thing, sorry - I'm using a Mac Pro (2x2.26 GHz Quad-Core Intel Xeon, 8GB 1066 MHz DDR3 RAM) running 10.6.7, with After Effects CS5 10.0.2. No updates needed for either the system or the software.

All assets are on a local drive assigned for project files and assets. All of the other assets are working fine - it's just these two files. The Illustrator file is upscaled tremendously for a transition, and I originally thought that maybe there was a limitation on what scale an asset could be rendered (almost like a clipping plane - but they are visible and work beautifully in a RAM preview, furthering my confusion). I tested them in separate projects (including the scaling) and and they render well.

I have several iterative revisions, but these assets were incorporated several revisions back, and since the assets were working in After Effects (including in RAM previews) I didn't even think that there might be trouble with the assets when rendering. I was just hoping I wouldn't have to go several iterative revisions back and redo the work - but it looks like I may have to.

Thank you very much for your time and assistance,
Chris


Return to posts index

Dave LaRonde
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 8:29:12 pm

The only things that immediately come to mind are 1) you may be using some files in CMYK and not RGB AND 2) these files may have been modified to either add layers or incompatible layer styles.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Dave Johnson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 8:39:48 pm

It does sound like the issue is with the AI & PSD files, rather than AE per se ... as Dave alluded to, have they been altered in any way since they last rendered correctly? If so, how?

Oftentimes the simple process of clearing out what both AE and your system are currently referencing can solve strange anomaly type issues like what you're experiencing ...

Perhaps purge all of AE's cache from the file menu so any cached versions of and references to the problem files are gone.

Save out a copy of the AE project.

Restart your machine.

Duplicate the AI & PSD files, open the duplicates and re-save them without changing anything (unless you find something wrong like CMYK).

Open the AE project copy, replace AI & PSD files with the re-saved duplicates, then try another test render.


Return to posts index


Elizabeth Kaiser
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jul 12, 2012 at 12:30:29 am

I actually created an account specifically to thank you for this response. I have been trying to figure this issue out for the last hour and I just stumbled upon your answer. It just saved my butt majorly. So thank you. :)


Return to posts index

Dave LaRonde
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 7:51:22 pm

I understand you're in a panic, but you've given us NO information to let us help you. It's like walking into a hospital, yelling "I'm deathly sick with and I don't know why!" and expecting a cure on the spot.

Doctors can't work that way, and neither can we.

Doctors CAN tell pretty much everybody, "Eat healthier, don't smoke and get plenty of exercise". So here is advice along those lines:
  • TURN OFF OPEN GL ACCELERATION FOR RENDERING! Never use it.
  • Turn off multiprocessing if you have 8 GB RAM or less.
  • On all pre AE-10 versions, convert long-gop movie footage to a lossless codec.

Without useful info, that's all I can recommend. Oh wait, here's more: stand up straight, don't slouch, eat all your vegetables and don't play in traffic.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Dave Johnson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 8:10:17 pm

Until reading this one, I had recently started to wonder - what has this impostor done with the real Dave LaRonde!? Welcome back!! lol

BTW, you forgot one ... don't tug on Superman's cape.


Return to posts index


Walter Soyka
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 13, 2011 at 8:30:23 pm

[Chris Feldmann] "The layers are neither set as a guide layer"

Guide layers would have been my first guess.

Any chance that they're 3D layers, and you're RAM previewing some view other than the active camera?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Kevin Camp
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on May 14, 2011 at 3:34:39 am

I'm sure the urgency is over by now, but for the sake of troubleshooting...

If you want to troubleshoot the files, try bringing the files into a new comp and do a quick test render.

If that works, then it may be how the layers are being used, or effects on those layers. Try a copy/paste of those layers from the original comp into a comp by themselves and do a test render. If it doesn't render properly, start disabling effects or resetting properties until you can figure out what's wrong.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Saadi Alkouatli
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Oct 15, 2012 at 3:43:06 am

Thanks Walter, you saved me with your answer! I clicked on a layer by mistake and made it a guide layer.


Return to posts index


Lucas Moore
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jul 4, 2013 at 7:01:36 pm

In my comp, a PSD wasn't rendering. I had accidentally activated the guide layer. Right clicking the affected layer and un-checking "guide layer" solved it for me. Thanks!


Return to posts index

Christopher Cook
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jun 25, 2011 at 3:10:51 am

This response is obviously not timely, but I'll leave my findings here since this thread came up when searching for help on this topic.

I have been experiencing this same issue with more and more frequency over the past few months - that of having layered Illustrator files* importing fine, working with them without abnormality, and then having to pull my hair out because they simply aren't there in any outputs.

When I first experienced it, these elements would function normally in RAM preview, making it doubly confusing that they would be visible and functioning when scrubbing the timeline and when previewing, but then not exist when rendering.

As the months have progressed, and as was occurring today, the files have frequently been electing to opt out of the Preview renders as well, presumably because they're catching up on their Hulu queue and can't be bothered just at that moment. Perplexing.

These files are RGB. They are not Guides. They are stored locally. Purging, reloading, restarting, refreshing, et cetera has no effect.

To speak to my own non-dunce-ity, I worked on semi-large project each in November, December, and January that were comprised almost entirely of characters and elements layered out in Illustrator, imported as Compositions into After Effects, and animated without issues of elements not rendering. In March I began experiencing these issues.

Aside from trying it dozens of times in the hope that one will catch, the only solution I've found is to just not use AI files. This is certainly not ideal, but neither is not having a product to show the client. Exporting each layer individuals as EPS out of Illustrator and importing these into After Effects has proven it to cause no issues at all.

The major impairment with this work around is that you would have to re-align all of your layered elements within AE.

What I did, since I had already imported the AI as a composition, which imports it in separate layers and retains the layers' sizes (this is the default - don't select "Document Size for this work-around)...what I did was to import the EPS's of the individual layers and then replace the AI file layers with the EPS of the corresponding layer...if that makes sense.

That saved me from having to reanimate and anchor and adjust the whole thing a second time. Not ideal as the AI working, but it worked.




So, bottom line, go EPS
. Use that handy "Export As" option.




That is, at least, what worked for me. I honestly suspect it's an odd bug. Wasn't an issue 6 months ago, but now is an issue. I'm due to reformat the machine but am just (luckily) too busy to drop a day. I'll try to remember to update my findings once I do reformat and reload everything anew.

Working on PC Win7 6-core i7 3.33Ghz 12-GB DDR3 CS5 Production


Best of luck to all until then.

Christopher Cook
Brainroot Light and Sound




*no experience with this happening with PSDs, but I haven't worked with complex PSDs


Return to posts index

Chris Feldmann
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jul 5, 2011 at 5:06:15 pm

Thanks to all who replied. I'm still not entirely sure what the issue really was - but ensuring that the files were RGB and not CYMK (I'm new to working with graphic designers and used to creating my own assets - so checking for something as simple as that slipped my mind) and exporting as a different file format did the trick.

Thank you all very much for your time once again.


Return to posts index


Rc Johnson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Sep 23, 2011 at 5:51:10 pm

I've found that with most of the AI files I have this rendering problem with, it's resolved by working locally and by turning on the layers continuous rasterization button.


Return to posts index

James Hobson
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Mar 26, 2012 at 9:40:45 am

@rc Johnson

Thanks so much - turning on continually rasterize fixed blank RAM preview and renders.. *sigh of relief*


Return to posts index

Coby Randal
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Mar 29, 2015 at 1:16:18 am

Hey guys, I know this is an old thread, but I wanted to add a solution that helped me out (using After Effects CC 2014).

One of my layers was not rendering because it was set to "Guide Layer". Simply right click it and uncheck "Guide Layer". Renders great :D.


Return to posts index


chris homer
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jun 29, 2015 at 2:25:31 pm

Hey Guys, I have had the same problem today with AE 2015. Turns out the problem was because I had pre composed 3d objects. When I turned off the accept lights off on all the materials in the pre comp the render worked.

cheers


Return to posts index

Eugene Baritskiy
Re: PLEASE ADVISE ASAP! After Effects will not render SOME assets.
on Jul 31, 2015 at 1:10:46 pm

Hello everyone. I have the same problem and can't resolve it. I don't have any Guide Layers and I am not using AI files. There are just few PNG's in very high resolution (5760x3240). They are render well if I choose crappy quality, but if I choose Best quality I don't see anything. Also I see them just fine in After Effects preview (using spacebar).

I have latest After Effects CC on iMac i7 (24Gb RAM).


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]