MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Hair cache calculation doesn't stop

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Natalia Chebotar
Hair cache calculation doesn't stop
on Jun 18, 2020 at 12:15:48 am

Hi guys! Could you help me, I've got a problem with hair object and I can't find a solution anywhere. 

I have a complex object with hair (a lot of!), dynamics and hair-to-hair collisions. I clicked "Calculated cache" in the hair object, it went through all the frames, took more than a day. C4D didn't respond all that time, but it didn't crash (the current frame changed, everything looked fine). But now it started calculating again from the first frame! And it still doesn't respond. 

I have no idea what to do. I don't know how to stop the process, and I don't want to force quit the app because it will destroy all the cache and I'll waste too much time to calculate it again. 

Any advice?


Return to posts index

Sam Treadway
Re: Hair cache calculation doesn't stop
on Jun 18, 2020 at 2:14:53 am

Sometimes there is a way to send requests when the frame advances. You can keep pressing or try holding down command+W. If the scene has changed at all since the last save then this will invoke the "do you want to save changes...." dialog. The great thing is that once that dialog is active, command+W will no longer work until you click a button.
Save the file, close and reopen it. If you pressed play then reopening will continue to play forward which could be a problem. In that case, create a new scene and merge the original into it.

This could be an issue with display in the viewport vs collision calculation time. Do you have the hair display mode site to guides or the actual hair lines or geo?


Return to posts index

Natalia Chebotar
Re: Hair cache calculation doesn't stop
on Jun 18, 2020 at 8:45:10 am

Oh thanks! I like the Cmd+W idea, trying it now. Tried to click it a few times, didn't work, so I just put a couple of erasers on the keyboard and a heavy book on top of them, waiting for the result 😝

I don't think it is the viewport issue, it's set to show guides only.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]