MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

xp splineflow problems

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ignacio Triana
xp splineflow problems
on Oct 24, 2019 at 4:36:19 pm

Hey everyone, I'm trying to create a branching object that follows a helix spline.

I'm using particles 4 in C4D studio R18.

I'm not having any luck getting the particle to follow the spline.

Ive messed around with the different controls within xpspline flow, made adjustments within the individual handles and still can't get the particle to follow the spline. The spline is dragged into the spline tab of xpspline flow as well.

I don't know if there's a simple tag or setting I'm neglecting? Any help with this would really help me get some control over these crazy particles and branches.

hope everyone is well

Ignacio


Return to posts index

Jim Scott
Re: xp splineflow problems
on Oct 24, 2019 at 5:28:43 pm

All that is required is that the spline is dragged into the "Spline" tab, which you have done. Make sure that the emitter is near the beginning of the helix, and that its emission direction basically lines up with the spline, otherwise the particles may not be attracted properly.



13837_xpsplineflowexample.c4d.zip


Return to posts index

Ignacio Triana
Re: xp splineflow problems
on Oct 24, 2019 at 6:09:39 pm

thanks Jim! very nice of you. I tried with a simpler spline (an arc) and evenly spaced out the handles but got this strange effect of it going through first handle then just stopping and not continuing the path. the emitter is placed right at the head/tip of the spline.

the particles look like they hit a ceiling/stop moving?

I set the emission to Rate, Emit all frames & full lifespan.

let me know if you have any thoughts? I appreciate your time.

hope all is well

Ignacio



dip



Return to posts index


Brian Jones
Re: xp splineflow problems
on Oct 24, 2019 at 5:30:16 pm

with a helix you'd need more handles that the default, so add some so you have 8 or 10 handles then Redistribute the handles to make them even


Return to posts index

Ignacio Triana
Re: xp splineflow problems
on Oct 24, 2019 at 6:11:10 pm

that makes sense, thanks! though right now I'm having a hard time getting particles to go through three handles let alone ten, ugh.

hope all is well

Danny

dip



Return to posts index

Brian Jones
Re: xp splineflow problems
on Oct 24, 2019 at 6:13:11 pm

the spline direction makes a difference so you might have to reverse the spline


Return to posts index


Ignacio Triana
Re: xp splineflow problems
on Oct 24, 2019 at 6:34:29 pm

oh geez, that made big difference. I increased the speed and lined the emitter up and angled it accordingly. was a simple fix that I don't think I would've stumbled onto.

thanks for your time.

Ignacio



dip



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]