MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Xparticles and dynamics

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Oidryn Karaz
Xparticles and dynamics
on May 1, 2019 at 6:59:38 am

Hi guys, long time lurker here looking for some help.

I have a simple setup with an attractor and some spheres, this piped through xparticles xpgenerator, it looks like little atoms popping into existence, well it does in the viewport after i have set initial state it almost works as expected. However in the render images all the dynamics I have in my viewport stops working. I have tried caching the dynamic body tags. I have tested it without running it through the xpgenerator and it works by itself. I also read here that its better to have editable geometry so i converted all the sphere to editable. I also read sometimes render settings are different to the vieport geo settings? If it wasnt for the working viewport i would just assume dynamis doesnt work through xp like that. Any ideas?


Return to posts index

Brian Jones
Re: Xparticles and dynamics
on May 3, 2019 at 2:09:31 am

you may have to post the scene file, but -- xp and dynamics are different sim systems so won't cooperate. If you have rigid body tags on generated objects (editable or parametric doesn't matter) the dynamics will take over the particles will still move where xp takes them but the dynamics will move the objects once they are born. If you want to see what the Dynamics are going to do you have to generate the particles while testing, if you have the xp doing things to the particles stream but you want collisions you have to use the collisions system in xp.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]