MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Spline Wrap causing severe pixelation

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Guy Smith
Spline Wrap causing severe pixelation
on Apr 4, 2019 at 7:39:27 pm

Using Spline Wrap on geometry imported from a CAD app into C4D causes the geometry to look severely pixelated when rendered. When Spline Wrap is removed the geometry looks fine again (see images).

Any ideas?





Return to posts index

Brian Jones
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 3:18:10 pm

and the text disappears too. Hard to guess with no other info. What are you doing with the spline wrap? Shortening it? Does it have a Normal tag from the import process? If so, try dumping that, though as Steve said recently Phong tags on import can have Angle Limit and Phong Angle problems so you can try adjusting those.


Return to posts index

Guy Smith
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 4:08:42 pm

Sheesh. I tried EVERYTHING... except deleting the Normal tag.

That completely solved my problem, THANK YOU Brian!


Return to posts index


Guy Smith
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 5:19:27 pm

Looks like I spoke too soon, deleting the Normal tag solved the problem on the spring portion of the assembly but not on the solid portion at the end of the spring.

Is there any other info. I can provide to help diagnose this?


Return to posts index

Steve Bentley
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 9:27:18 pm

Did I hear my name? Nope, can't be, it wasn't preceded by cursing.
Whats the spline wrap being used for? Its not that the geometry just isn't there right? The model will render smooth with out the spline wrap being there somewhere?
Is the model a child of a parent that has a phone tag that is filtering down through the children? You can take the tag from the child but if the parent has one it will take over. (wow I was really tying to make that a "take the boy out of the town... thing but it wasn't helpful).



Return to posts index

Guy Smith
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 11:01:00 pm

--- Did I hear my name? ---
Quite possibly, I was dreaming earlier.

---Whats the spline wrap being used for?---
Context is everything: It's an inspection camera for sewer and drain pipes. A camera head is attached to the end of a spring, which is attached to a fiberglass cable. The whole assembly snakes its way out of the drum and through three guide hoops. I uploaded a pic of the equipment for reference.

--- Its not that the geometry just isn't there right?---
Correct. The geometry is there.

---The model will render smooth with out the spline wrap being there somewhere?---
Yes, the model looks fine when Spline Wrap is removed.

---Is the model a child of a parent that has a phone tag that is filtering down through the children?---
I prefer to not involve myself in parent/child issues.... But seriously, objects are grouped under nulls and I didn't see any tags applied to the nulls, just the child objects within.

---You can take the tag from the child but if the parent has one it will take over---
Ok, that makes sense.



Return to posts index


Steve Bentley
Re: Spline Wrap causing severe pixelation
on Apr 5, 2019 at 11:13:58 pm

ya that should have been "phong" tag - stupid spell check..
What was the model created in?
So the spline is what comes out of the hub so the camera can extend right?
What kind of file is it that you brought in from the CAD package? (what extension?)



Return to posts index

Guy Smith
Re: Spline Wrap causing severe pixelation
on Apr 8, 2019 at 3:44:08 pm

"So the spline is what comes out of the hub so the camera can extend right?"
Correct.

"What was the model created in?"
SolidWorks

"What kind of file is it that you brought in from the CAD package? (what extension?)"
NuGraf uses the SolidWorks run time to open SolidWorks assemblies (SLDASM). Once opened and assembly can be exported in a number of formats, I export as a C4D native file.


Return to posts index

Steve Bentley
Re: Spline Wrap causing severe pixelation
on Apr 8, 2019 at 3:53:03 pm

Hmm, I'm wondering if the export path is the culprit. We have SW here and we use the STL export from SW to bring the model into C4D. The ASM format has all the information for say, a sphere to be completely smooth but doesn't have any geometry perse. That format is really meant for G-code (or similar) generation, or for the SW viewer to generate real time viewings of the parts and cross sections.
While there must be geometry there or C4D would just not see it, (and of course that you can get it smooth in some renders) I'm wondering if adding in certain new objects interrupts the tessellation order of the SWASM in C4D.
Have you got the original SW file? Can you try STL? The great thing about STL is that you can tessellate it in SW to the mesh density you are looking for (that's the "options" button just before you hit save).



Return to posts index


Guy Smith
Re: Spline Wrap causing severe pixelation
on Apr 9, 2019 at 11:09:10 pm

Thank you, I'll try an STL workflow and increase the mesh density.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]