MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Explosion FX Triangulation Issue

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Filip Stillerska
Explosion FX Triangulation Issue
on Mar 16, 2019 at 7:14:03 pm

I want to use Explosion FX on an object:


But when I do, the mesh becomes extremely triangulated for some reason... I've tried changing the Explosion FX settings (for example, the Cluster-settings) but it doesn't solve the problem:


Close up:


Applying a texture/material doesn't help.

Feel free to download the file and try it yourself: https://www.dropbox.com/s/a6rf5yfejfwrlau/GirlCharacterExplosionFXIssue.c4d...

Any ideas?


Return to posts index

Jim Scott
Re: Explosion FX Triangulation Issue
on Mar 16, 2019 at 8:58:34 pm

The Explosion FX doesn't change the mesh but only works with the mesh that it is given. With the Explosion FX disabled (or before applying it) select Display > Gourad Shading (Lines), or keyboard shortcut N > B, to see the mesh. You will then see that the figure's mesh is made up of the same triangles that are used by the Explosion FX.





Return to posts index

Filip Stillerska
Re: Explosion FX Triangulation Issue
on Mar 16, 2019 at 9:41:19 pm

Thank you, Jim! Very good and clear explanation with screenshots.
However, is there any way to avoid this triangulation thing from happening so visibly? I understand that the Explosion FX needs to break the mesh into triangles, but the Explosion FX is kind of useless if the mesh becomes so visibly "distorted", unless you're creating an explosion that is so fast that the audience won't be able to see this triangulation process. I want to use the Explosion FX to create a "slow" explosion, to simulate something that looks like a disintegration effect. I guess that won't work, apparently...


Return to posts index


Jim Scott
Re: Explosion FX Triangulation Issue
on Mar 16, 2019 at 10:06:08 pm

Hi Filip,

The Explosion FX is not breaking the mesh into triangles -- the mesh of the figure is already triangles. Explosion FX simply explodes them apart. Try the Explosion object with the speed set to zero, and animate the strength from 0 to 100%, and see if that's what your after.



Return to posts index

Jim Scott
Re: Explosion FX Triangulation Issue
on Mar 16, 2019 at 11:57:52 pm

To minimize the look of triangles flying apart subdivide the mesh a few times -- Mesh > Commands > Subdivide (or U > S). In my example below I subdivided twice and applied the Explosion object with a speed of 10 and animated the Strength from 0 to 100% over two seconds.

13210_explosion.mov.zip


Return to posts index

Steve Bentley
Re: Explosion FX Triangulation Issue
on Mar 17, 2019 at 2:47:21 am

Perhaps what you are seeing is the mesh once its separated. With the triangles together the phong shading creates a smooth transition between polys (that are less than a set angle of difference). As soon as you separate the polys the phong tag is rendered pointless and you see each triangle as a flat surface and any reflections are severely harsh.



Return to posts index


Filip Stillerska
Re: Explosion FX Triangulation Issue
on Mar 17, 2019 at 8:39:36 pm

Unfortunately I don't have the Explosion object or the option to subdivide; I'm using Cinema 4D Lite.
However, I found a workaround: first I rendered the scene with the Explosion FX, and then I rendered the scene again with the Explosion FX disabled. Then I comped these together in AE. Not the ideal workflow - but once again I'm limited by C4D Lite. The end result is exactly what I wanted to achieve, though.


Return to posts index

Jim Scott
Re: Explosion FX Triangulation Issue
on Mar 17, 2019 at 9:46:33 pm

I'm not familiar with C4D Lite so I wouldn't have known what capabilities it was missing, but I'm glad you got it worked out.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]