MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Strange polygon jittering/flashing SOFT BODY

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Riaan Myburgh
Strange polygon jittering/flashing SOFT BODY
on Feb 22, 2019 at 11:08:04 am

Hi,
The objective I have is to fill a room with paper.
I am using an emitter to create planes with softbody tag attached which works fine except that I am having some issues with flickering polygons and jittering movement once it fills up a bit.

Any insight as to how to clean this up a bit would be greatly appreciated

link to a gif showing the issue
https://imgur.com/Fd4zAbR

Link to video showing the issue in full (specifically the base of the room)






Return to posts index

Brian Jones
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 22, 2019 at 4:21:24 pm

hard to tell with the full length vid with all the artifacting from compression but it's clear enough in the gif. I would guess it's the kind of motion you get from softbodies when they interpentrate and explode but it's really restrained. You'd have to try and remove some energy from the collisions would be my guess but what's happening with the one piece of paper, close to the top near the end of the second run in the gif, that just appears for one frame the disappears entirely is something else. All of it's pretty touchy when trying to pile objects particularly with soft bodies, it would help to have the scene to play with for tweaking values.


Return to posts index

Riaan Myburgh
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 25, 2019 at 7:12:49 am

Hi Brian,
thank you for taking the time to assist.
Here is the project file if you want to fiddle with it.
I feel like I have tried every possible configuration of edits on the springs of the soft body with no real luck yet. I will try crank up the damping on all parameters as well and see what happens!

https://www.dropbox.com/s/ihjs530qgvw8w82/PaperVideo.zip?dl=0


Return to posts index


Riaan Myburgh
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 25, 2019 at 12:58:54 pm

is it possible that my render resolution has something to do with it?
I am rendering at 360x640 for the sake of getting faster results


Return to posts index

Brian Jones
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 25, 2019 at 3:25:07 pm

I don't think it's the resolution, here's a test I ran. Shortened to 100 frames, with aspect ratio changed so I can watch the bottom of the box, removed collision noise in the box colliders (major problem in any long anim with lots of objects) and cranked the stiffness and damping in Structural and Flexion. It's a lot more stable in the pile with those settings, though I'm only going to 100 frames to be quicker but it still makes a major difference from the original settings over that same range of frames.

13152_ccsample2.c4d.zip


Return to posts index

Riaan Myburgh
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 26, 2019 at 8:38:45 am

That is great thank you!
I don't think I was pushing those values far enough, they seem a bit arbitrary.

The only thing that isnt quite working right is the downward compression now, I am going to fiddle around with mass and density to see if it helps but not sure that is something we can get rid of


Return to posts index


Brian Jones
Re: Strange polygon jittering/flashing SOFT BODY
on Feb 26, 2019 at 12:48:52 pm

Push the Structural value up higher, I was primarily interested in Flexion since that is the stiffness that seemed most likely to be the problem. Check out the help for more info. And yes the values are what they are, not necessarily ‘real’ but it is a simulation.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]