MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

How to stop hair showing in reflective material?

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Millen
How to stop hair showing in reflective material?
on Jan 17, 2019 at 12:29:39 am

I have tried everything. All I want is to render some grass (hair) that does not have a reflection in the water-like material right below it. The compositing tag does not seem to have an effect, no matter where I put it. I even tried converting the hair to editable geometry and it still showed up in the reflection. What am I missing?

Using C4D R20 with standard renderer. Hair Render is on in render settings.


Return to posts index

Brian Jones
Re: How to stop hair showing in reflective material?
on Jan 17, 2019 at 3:40:32 am

can't tell without the scene file - here the hair is reflected with a Compositing tag with Seen By Reflection turned off but once Generate is set to Flat, Triangle, Square or Circle (and I assume Instance if you provide one) the reflection disappears.


Return to posts index

Andrew Millen
Re: How to stop hair showing in reflective material?
on Jan 17, 2019 at 4:26:22 am

I tried that, and the hair seems to disappear from the render entirely when I do. I have attached the scene file. When I then try to make the object editable, the hair changes direction (??) and becomes visible again, but also appears in reflection. Very confused.

Here's a link to the test file: https://www.dropbox.com/s/v3yas9w2awa7jhg/Grass%20Test.zip?dl=0


Return to posts index


Emir Bojorquez
Re: How to stop hair showing in reflective material?
on Jan 17, 2019 at 3:58:55 pm

Your object is on a Transparent Plane.
You need to :

1 Generate a geometry for your hair (Flat, square or so).
2 Because your hair has a geometry now, you need to Unchild the hair from your Transparent Plane to Avoid the transparent material to be
applied to the hair.
3 Go to your Compositing Tag >> uncheck Seen by refraction (because of the transparent object).
4 Go to your Compositing Tag>> Exclusion >> add the Water Plane here.



Hope that helps.

Good Luck

Imagination is the best tool...



Return to posts index

Andrew Millen
Re: How to stop hair showing in reflective material?
on Jan 17, 2019 at 4:50:40 pm

That solved it, thank you!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]