MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Indexed noise for the Shader Effector?

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Penny Wayne
Indexed noise for the Shader Effector?
on Dec 31, 2018 at 7:46:22 am

So I have an issue I really need help solving. Here, I have a file for anyone to take a look into. For 'Comparison 1' it is just some cloned cubes and the material hooked up to them has a mograph color shader in the transparency section of the material. As you can see, if you play through the scene, it's randomizing in transparency at just the right speed I want, using the shader effector.

Now, take a look at 'Comparison 2'. Keep in mind both comparisons are using the same exact shader effector to accomplish the randomness. Now, play through the scene again, but take a look at Comparison 2. Notice how when the traced object moves, the randomness spazzes out and goes at a speed that I do not desire at all. Only when it comes to a stop will it start to go back to the speed I want. Now If I was to do this with a random effector, I can change the space to 'UV' rather than 'Global' to avoid having it spazz out the same way, but I would also need to have the checkbox 'indexed' enabled to make sure it is randomized and not using diagonal movement.

Go into the noise for the shader effector and change the space to UV. Now play the scene again. As you can see, it does not spazz out. Great! However, there is a new problem. We have lost the randomness. I don't see an option like 'indexed' and I really want to use the shader effector for this rather than the random effector for more control (ironically).

All I want is to be able to keep the randomness while avoiding it spazzing out every time the traced object moves through the scene as seen when playing the scene itself. Please, any help and ideas at all will be greatly, greatly appreciated.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 All Rights Reserved