MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Taming post collision objects

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Greg Sage
Taming post collision objects
on Nov 19, 2018 at 4:34:53 am
Last Edited By Greg Sage on Nov 19, 2018 at 4:52:45 am

Project file attached:

I've got a tiny emitter hidden behind an object, and emitter working fine with randomly sized objects, but when I turn on dynamics by applying either rigid body or collider body tag to either the objects themselves, or via the emitter with apply to child objects enabled, all my speed settings are meaningless because the objects shoot out at absurd velocity.

I assume this is due to the size of the emitter causing immediate collisions upon birth, but I can't make the collider any bigger due to other constraints.

I've searched through dynamics in project settings like where gravity is set and gone through the items in the dynamics tags one by one, and watched quite a few tuts on related topics, but just haven't quite found the right setting, and I'm not sure what it's called to reference it.

There seems to be an additional issue that I have emission pattern radiating out in disc formation, so 360 degree emission for horizontal, and 0 degrees on vertical which does exactly what I want... until the dynamics tag is applied. Unfortunately, collided objects appear to ignore this and travel in all directions which breaks the animation.

Basically, how do I force collided objects to either slow down or just disappear, and I can readjust the emission density from there? If the objects do persist, and are slowed down, is there a way to force them to be restricted to the 2 dimensional radiation as defined within the emitter? (zero vertical)

12893_emittercollisiontest.c4d.zip


Return to posts index

Brian Jones
Re: Taming post collision objects
on Nov 20, 2018 at 2:09:51 am

what are the dynamics for? Gravity is turned off, the cube and the background don't have collider tags, so all the dynamics tag will do is to cause the particles to shoot around when the particles are born inside each other and nothing else would cause them to collide as the scene is setup now. Turn off Self Collisions so the particles won't interact with each other looks like the deal but that would be the same as removing the tag altogether...


Return to posts index

Greg Sage
Re: Taming post collision objects
on Nov 20, 2018 at 1:30:24 pm

It's specifically to stop them from being on top of each other so I get individual balls coming out rather than blobs. You are correct that self collisions are the only thing at issue... but while I can't avoid them occurring due to the emitter size, I'm trying to avoid SEEING them once they clear the emitter.

After extensive trial an error, I believe it was changing the "time constant" to 0.1 that more or less got the post collision speed to match pre-collision. It also stablized the crazy mismatch in rotations pre and post that becomes obvious once the spheres are texture wrapped. That much is stable, but I still haven't been able to fully fix the issue of post-collision objects breaking the emission plane.

Since it's such a simple scene and just being used as one layer in an AE comp, though, I faked it by just putting lots of distance between the objects so it effectively keeps the balls from breaking the foreground or background planes. Good enough to move forward, though I would always like to learn why something happens for next time.


Return to posts index


Brian Jones
Re: Taming post collision objects
on Nov 20, 2018 at 5:11:48 pm

if you were using Thinking Particles (I assume no XParticles) you could have the particles be zero size for the first while then get bigger.


Return to posts index

Greg Sage
Re: Taming post collision objects
on Nov 21, 2018 at 4:52:19 pm

OK. Will look into that. Thx.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]