MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Sketch up model coming in with way too many polys

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Goldberg
Sketch up model coming in with way too many polys
on Nov 3, 2018 at 4:00:16 am

Hi,
We're currently trying to bring a sketch up model into C4D (V19). We had no luck importing directly, so we're using sketch up to export either an FBX, or Collada model. We can get the model into C4D, but there's just way too many polys. I can't even move around to figure out where to delete or merge objects. It's showing as 15 mil polys. The model is an entire building with individual rooms inside. Any suggestions on how to reduce this, or how to export it differently from sketch up (I have 0 experience with sketch up)?

Mike



Return to posts index

Steve Bentley
Re: Sketch up model coming in with way too many polys
on Nov 5, 2018 at 12:50:21 am

Sketchup makes models that are "water tight". In other words solids. C4D can do that too but it's more of a surface modeller. Its probably that C4D is interpreting the inner sides of walls and wall ends as polys too (as it should) when you just need the outer skin.
If you have a rectangle of poly's in the middle of a wall in sketch up, and you grab that face and pull, you get an extrusion coming out of the wall. If you do the same in C4D you end up distorting the entire wall, so C4D doesn't push and pull geometry around without you first telling it to extrude (and even then not was well as Sketch up or Solid works). So there is extra info there in the SKUP file that C4d normally doesn't have to deal with.
Try an OBJ export as there are often settings in the export where you can trim inside faces, combine coincident faces etc that may reduce the overall poly load.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]