MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Dynamics cache disappearing when I close and reopen project

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Xavier Bonet
Dynamics cache disappearing when I close and reopen project
on Jun 4, 2018 at 10:26:05 am

So I spent several hours getting an array of falling objects to fall as close to where I wanted them to fall as possible using dynamics. I baked everything. Saved the project, copied the entire folder onto an SD card, and transferred it to my rendering computer. When I saw the final render: no objects were falling! I checked the project, and no objects were falling either. They just stayed up there, in their initial state, even though all dynamics tags said they had cached info. Thinking maybe something "broke" when transferring the project form one computer to another (although, why would it?) I went back to my original project and, lo and behold, the same issue there: cached info but nothing moves. So I had to clear the cache and re-bake... which, of course, who knows why?, now is giving me a complete different result. But, in any case, if I save, close the project and reopen it: the dynamics disappear, even as the cached data is still there... Shouldn't baking dynamics ensure that you can forget about them and have them there, working always the same as a manual, keyed animation would?


Return to posts index

Jim Scott
Re: Dynamics cache disappearing when I close and reopen project
on Jun 4, 2018 at 8:46:53 pm

Hi Xavier,

In doing a simple test with some falling blocks, baking the cache, and saving the project, when I reopened the project the cache was still present and worked as expected. Did you confirm that in your project's dynamics tags the "Use Cached Data" box was not inadvertently unchecked? It shouldn't happen by itself, but it's something to check.

When you wrote, "I checked the project, and no objects were falling either. They just stayed up there, in their initial state, even though all dynamics tags said they had cached info," did you mean that you could not scrub through the timeline and have the objects fall, or were they motionless when hitting play, indicating that the dynamics tags themselves weren't working? Does your rendering computer use the same version and edition of C4D as your main computer (as some editions do not include Dynamics)?

If you could post your project file (with baked cache) I will see what result I get. And if the dynamics don't work for me I will try rebaking the cache, saving the project, and reopening it to see if that process is working as it should.



Return to posts index

Xavier Bonet
Re: Dynamics cache disappearing when I close and reopen project
on Jun 4, 2018 at 9:03:25 pm

Hi, Jim! Thanks for your response.

I did check if the "Use Cached Data" box was checked. I started turning things on and off to see what was the problem, and I found that I was having problems with the objects that had a bend deformer attached to them and a dynamics tag. So I got rid of that deformer by converting the entire object, bend and on, into an editable object, which solved the issue.

Now, to answer your questions. In both computers (which are using the R19, and which I use always one after the other, to build a project and then to render it, respectively, with no problem at all) I saw the same result: when I opened the project back up, the objects wouldn't even fall when I scrubbed the timeline, they just hung in the air, like you said. BUT, the interesting thing is that even when I rebaked everything and tried rendering the project from computer 1, instead of closing it and transferring the project (i.e. the baked data was working, everything was OK when I scrubbed), in the final render the objects with the dynamics tags that are giving me the issues didn't appear... as if they were transparent or turned off to the camera—which is a first for me. So there is that, too.

I was working rather fast because I had to turn in a final render a couple of hours ago, so I'm not sure if I saved my workaround over the initial file with the issue... 😖 I hope it's in one of the 2 computers, so I can upload it and maybe we can get to the bottom of why something like this is happening. Any ideas why it would work in the preview and not in the final render?


Return to posts index


Jim Scott
Re: Dynamics cache disappearing when I close and reopen project
on Jun 4, 2018 at 9:48:47 pm

I'm glad you got it sorted out, but off the top of my head I can't think of any reason (other than turning them off in "Visible in Render") that the objects would appear in the preview but disappear in the final render. Very odd.

If you find the file and want me and others to test it, perhaps make a new thread to attract interest.

Good luck.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]