MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Soft Body Dynamics - weird "crunching" issue on default settings...

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ray Zane
Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 8, 2018 at 2:55:08 pm

I have a snapshot of a cube with 10 segments on every axis and have applied a Soft Body Tag with no settings changed (just default). The floor Plane just has default Collider Tag settings.

I have no idea why I am getting this issue. The entire shape is almost shattering instead of dropping like a piece of jello. Something is broken here and I have idea what.

On top of that, the render preview takes an eternity. I have nothing else going on in this scene other than the Plane, the Cube and those dynamics tags mentioned before.

Please HELP!



softbody.png


Return to posts index

Jim Scott
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 8, 2018 at 9:41:07 pm

To smooth out the soft body dynamics increase the Steps per Frame in the Project Settings:



Unfortunately that will further slow down the animation preview in the viewport, which is already an issue for you. If that just started, try a reboot. Otherwise I don't know what to suggest.



Return to posts index

Brian Jones
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 8, 2018 at 11:17:45 pm

doesn't do that here, what version of C4D?


Return to posts index


Rob Mason
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 9, 2018 at 3:31:15 pm

In response to both of you, I have version R18 and I did try increasing the Steps and all it does is slow down the render even more and doesn't solve the issue.

I found a helpful method for "controlling" and speeding up the soft body dynamics using the Mesh Deformer and a Cage, here is a link:





It has helped, but I am still at a total loss as to why this is happening. Furthermore, I cannot use the Mesh Deformer trick from that link in Cloners...which is a major bummer for my project...


Return to posts index

Jim Scott
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 9, 2018 at 6:43:09 pm

Post your project file so that we can take a look at it.



Return to posts index

Rob Mason
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 11, 2018 at 8:46:03 pm

Sorry for the late reply. Here it is...


Return to posts index


Rob Mason
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 11, 2018 at 8:50:17 pm

12241_bouncyballtest.c4d.zip


Return to posts index

Jim Scott
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 11, 2018 at 11:19:02 pm

Here is your project with some slight modifications:

1) Object type changed to Icosahedron for more uniform polygons.
2) Render Perfect deselected, otherwise the render would create a perfect sphere for every frame (no deformations)
3) Soft Body settings - Stiffness increased from 0 to 30
4) Steps per Frame - increased from 5 to 20

On my machine (2012 Mac Pro with dual 6-core 3.4 GHz Xeon processors with 64 GB of RAM) the first 70 frames of the animation (where all the action takes place) took 18 seconds to render an Apple ProRes 422, 1280 × 720, movie file. I would estimate that playback in the viewport was 15-20 fps.

12243_bouncyballtestmodified.c4d.zip

I hope this helps.



Return to posts index

Rob Mason
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 13, 2018 at 6:34:01 pm

Wow. Thank you so much Jim Scott!


Return to posts index


Jim Scott
Re: Soft Body Dynamics - weird "crunching" issue on default settings...
on Mar 13, 2018 at 8:30:53 pm

You are very welcome. Hopefully all of your issues were addressed.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]