MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Dynamics setup

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve Renard
Dynamics setup
on Oct 7, 2016 at 2:43:55 pm

I am setting up a fairly simple (I think) dynamics animation where three bins fall and land with very little bounce (they're heavy) and then a bunch of cloned boxes fall into the bins right afterward, with almost no bounce whatsoever (they're cardboard). I've run into several issues that I can't seem to solve and I'm hoping someone out there can make some workflow recommendations for me because I can't seem to find or figure out any way to stop this stuff from happening. I've included a screen grab below of the object structure - please let me know if there are other things I should be posting to figure this out.

Here's what happening:

1. I have three different elements interacting: the bins, the boxes, and the floor that they land on. The bins and boxes are grouped in a null that moves from "offstage" to "onstage" at the appropriate time, and then I've keyframed the dynamics "Enabled" checkbox right after that move, to start them falling. Depending on the state of the dynamics tag on the bins and boxes, it would seem that sometimes I'm able to edit their starting position and sometimes not. What determines my ability to edit them? Is there a switch I can turn on and off to correct them if I screw something up? For example, this morning I found that somehow I had told the dynamics system to put all the bins in the same place (more or less) and I wanted to get them back to being in a line side-by-side, but I could not seem to get them to move without deleting the dynamics tags. Surely there's a better way to handle this?

2. In that same situation where I had to delete the dynamics tags in order to change the position of the bins, when I applied new dynamics tags to those bins, they no longer interacted with my Collider Body floor, and so they fell right through it. I thought perhaps I had to apply the Collider Body after the Rigid Body tag, so I deleted it and applied it again, but the bins still fall right through the floor. I also looked for some part of each tag that would say "hey, you guys are all part of the same system" or something like that, but to no avail. What am I doing wrong here?

3. The bins are set to "moving mesh" to make the boxes fall inside them and not roll off the top, the mass of everything is fairly high (I just kept adding zeros till I liked what I saw), and the bounce of all but the floor is set to zero, with 100% friction. But still two weird things keep happening - the boxes bounce much more than expected, and occasionally they fall right through the bottom of the bin at the first impact. What gives?



Many thanks to anyone who can help - I am still fairly new to C4D and trying to get this shot to work has been a major headache.

Cheers,
Steve

------------
Steve Renard
647-406-7991
steve@steverenard.com


Return to posts index

Steve Renard
Re: Dynamics setup
on Oct 7, 2016 at 2:46:47 pm

I should add that the boxes still interact with the floor, it's just the bins that fall through. As I say - what gives?

------------
Steve Renard
647-406-7991
steve@steverenard.com


Return to posts index

Adam Trachtenberg
Re: Dynamics setup
on Oct 7, 2016 at 3:59:27 pm

As to the first question, you can move a dynamic object if the tag's "enabled" parameter is keyframed off, or if your timeline is at frame 0. Otherwise you can't.

I don't know why your bins started falling through the floor, unless the floor's dynamics tag was keyframed off. Everything with a dynamics tag should interact with everything else. There are no separate domains in Cinema.

You might need to go to Edit>Project Settings>Dynamics>Advanced and increase "steps per frame" to prevent objects from falling through the floor or missing other objects. Some of the other issues might be fixed by increasing "interations per step" and/or by reducing the error threshold.


Return to posts index


Steve Renard
Re: Dynamics setup
on Oct 12, 2016 at 1:55:39 pm

Thanks for your help - I never did figure out why things started falling through the floor but by adjusting the steps per frame at least I kept the boxes from occasionally falling through the bins. Maybe I'm doing something weird still but for whatever reason I still end up with bins falling through the floor if I try to change too many things. Have to get this project done so for now I'm chalking it up to a bug!

------------
Steve Renard
647-406-7991
steve@steverenard.com


Return to posts index

Brian Jones
Re: Dynamics setup
on Oct 12, 2016 at 2:23:08 pm

not likely to be a bug. Too late now by the sound of it but can you post the scene file?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]