MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Strange glitch with importing a model from Adobe Fuse into Cinema4D

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike Yan
Strange glitch with importing a model from Adobe Fuse into Cinema4D
on Jun 9, 2016 at 6:09:17 pm

Hello!

I started learning Cinema4D recently and got a weird glitch via importing a model from Adobe Fuse. Their models are free to use and have auto-rigging feature, so they are perfect for a start. I watched a few tutorials about importing that stuff into C4D and it's pretty straightforward with zero problems in the process. The thing is - it doesn't work for me. After importing a .fbx file a see this:



Whole model is transparent, but materials are present. Added a pair of light sources, but it's not working either. Here is the render view:



I used Adobe Fuse to generate a model from basic pieces, uploaded it for auto-rigging to Mixamo site, then downloaded it with a free animation. Importing the model without any animations gives me the same result. I followed step-by-step tutorials, and they don't have this problem.

Please, any thoughts on the problem?


Return to posts index

Brian Jones
Re: Strange glitch with importing a model from Adobe Fuse into Cinema4D
on Jun 9, 2016 at 11:18:15 pm

most of the textures look transparent (but maybe that's correct if the UVWs are correct). What happens if you remove all the Normal tags?


Return to posts index

Mike Yan
Re: Strange glitch with importing a model from Adobe Fuse into Cinema4D
on Jun 10, 2016 at 5:20:37 pm

Fixed the problem with disabling transparency on all of the materials. Strangely enough, default models from Mixamo site had transparency disabled, and all the custom models created by Adobe Fuse had it on after the import. Guess the problem is caused by some fresh update for C4D and/or Fuse.

Thanks!


Return to posts index


Paul Roper
Re: Strange glitch with importing a model from Adobe Fuse into Cinema4D
on Feb 2, 2017 at 11:31:34 am

I found my way to this post searching around because I have the exact same problem.

Initially I did the same as you - turned off the transparency of each material. But those transparency maps are, in some cases, actually doing something useful. I found that they are inverted - the transparency maps generated by Fuse/Mixamo are, as you'd expect, white = opaque, black = transparent. But C4D seems to expect an inverted matte - the opposite of an alpha channel.

(I suppose you could apply the logic that a greyscale map works like this:
white = 100% "activate the thing"
black = 100% "inactive"
...so 100% white means "activate the transparency" and black = "turn off the transparency", just as on a bump map, white = "activate the bump". Maybe).

So, I found that inverting the textures did the job. There's no one-click-invert way to do this, but instead of inverting the texture map in Photoshop, I set the black point and white point of the map to their opposite values (i.e. set black point to 1 and white point to 0). That inverts the image and fixes the texture. A bit of a pain to have to do this each time you import a model, to each texture. It'd be nice to see an "invert transparency maps" option when importing an .fbx model.

motion graphics | VFX | web design | etc.
http://paulroper.com/


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]