MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Smoothing CAD polygons

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
James McNellySmoothing CAD polygons
by on Mar 29, 2016 at 10:33:19 am

Hi

I have been given some CAD awk which I opened in some open source software, then saved it down to a .stl file.
I was able to then open in CINEMA 4D which is great.

However, the objects are just singular, so I can't adjust the amount of polygons they have, as I need to smooth everything out. I tried the subdivision surface but it didn't work due to the complexity of the single object. I presume I can't really do anything about this, and will probably need to remodel everything?

Any advice would be appreciated!

Thanks

J



Return to posts index

Brian JonesRe: Smoothing CAD polygons
by on Mar 29, 2016 at 2:53:20 pm

hard to say without seeing it (the file). Perhaps the file could have been output differently but some things you can't do much with. You might be able to join the pieces inside your object in C4D then optimize a bit before trying to smooth but that's hard to tell without seeing the file. It doesn't look hopeless just by the image but that's not enough info.
What was the original format (before you opened it in the open source)?


Return to posts index

James McNellyRe: Smoothing CAD polygons
by on Mar 29, 2016 at 3:16:46 pm

Hey, it was an .stp file which I managed to open in 'FREECAD'. I was then able to export it to an .stl file.

I found this thread, but it still didn't really help :(

http://www.cheetah3d.com/forum/showthread.php?t=59

Thanks!


Return to posts index


Phil LeideRe: Smoothing CAD polygons
by on Mar 29, 2016 at 3:55:39 pm

I am having similar problems with some OBJ files I am importing to render. Same idea - originally from CAD, converted to OBJ.

The workflow that I've found that works best for me right now is this:
1) Import OBJ
2) Reverse Normals
3) Optimize, with the tolerance set to 0
4) Apply textures
5) Set Phong to 5 degrees
6) Test render

This fixes most of the issues major banding issues, but sometimes it causes weird marks on flat surfaces elsewhere in the model. If it does that, sometimes playing with the Phong settings helps.

I've yet to find something that works 100% of the time. If you find anything else that helps, feel free to share.


Return to posts index

James McNellyRe: Smoothing CAD polygons
by on Mar 30, 2016 at 6:36:31 am

When I import the .obj into C4D I only have 3 options, should 'reverse normals' be in there too?
Would you mind pointing me in the direction of 'optimize' too please?

Thanks!



Return to posts index

Phil LeideRe: Smoothing CAD polygons
by on Mar 30, 2016 at 12:18:11 pm

They are both in the "Mesh" menu after the object is imported.

Mesh -> Normals -> Reverse Normals
Mesh -> Commands -> Optimize

When you use Optimize, there is a small box to the right of the menu. Click on it to bring up the options and change tolerance to 0.


Return to posts index


James McNellyRe: Smoothing CAD polygons
by on Mar 30, 2016 at 12:40:06 pm

ah cool, thanks so much!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]