MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Linking polygons to null object (to use in cineware/AE)

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andy Sills
Linking polygons to null object (to use in cineware/AE)
on Feb 16, 2016 at 9:30:19 pm

Hey guys,
I want to make it easier to animate in AE using motion tracking or anything like that.
My idea is this, if you have a c4d scene, and you have this object spinning around or whatever, and you want to maybe do some callouts in AE but instead of making the text static, you want to make it look like its in the scene....

The way I was doing it before was using cineware for the scene and doing motion tracking or something but I thought it would be cool to have a null follow the points in cinema so that when you extract the null in cineware, VOILA! You could have your text track that null in AE and you're good! RIGHT!?

I thought it would be easier but im pulling my hair out finding a way to do it.
The consensus is using a cluster deformer, but the problem with that is that you cant select points, you have to select the vertex mapping garbage and it doesnt follow the way you want.
ANY IDEAS GUYS!?!?!
PLEASE HALP, THIS WILL BE HUGE FOR ME ANIMATING STUFF!

Thanks so much!


Return to posts index

Adam Trachtenberg
Re: Linking polygons to null object (to use in cineware/AE)
on Feb 16, 2016 at 10:22:31 pm

I would make a duplicate of my polygon object, select the polygon(s) you want to use, invert the selection, and delete. Use Mesh>Commands>Optimize to get rid of the extra points. Then use Axis Center to center the axis on your polygon(s). Finally, add an external compositing tag to your object. Set the AE export option to export 3D data in render settings.

The external compositing tag will create an AE null on export, or if you want it can even create an AE solid.


Return to posts index

Andy Sills
Re: Linking polygons to null object (to use in cineware/AE)
on Feb 16, 2016 at 10:53:01 pm

hmmmmm not a bad idea at all!
I will try that tmw.
I just found a neat xpresso thing to do it and have the null follow the position of a specific point as well, I will post an update!


Return to posts index


Andy Sills
Re: Linking polygons to null object (to use in cineware/AE)
on Feb 16, 2016 at 11:40:35 pm

I THINK I GOT IT!
Ok I remembered the constraint tag, I just used the null then put the tag on the null and constrained it to the object.
So with that, and whatever animations were done to the orig object, then it grabs to it and everything is good!


Return to posts index

Adam Trachtenberg
Re: Linking polygons to null object (to use in cineware/AE)
on Feb 17, 2016 at 12:19:56 am

If you go with a constraint tag or Xpresso you may need bake the xpressions before you export to AE. But try it out and see if it works first.


Return to posts index

Andy Sills
Re: Linking polygons to null object (to use in cineware/AE)
on Feb 17, 2016 at 2:05:25 pm

Yeah thats the only drag when bringing it to AE, I cant find another way, its either duplicate the object or bake the movement, Im actually okay with the latter because it automatically copies the null object.
Wish there was more of a live way to do it.
But I like the constraint tag doing this because you can offset the anchor point WITHIN the tag.
WOO!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]