MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Roughness/Bump always cause "fireflies"?

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Joseph TamRoughness/Bump always cause "fireflies"?
by on Jan 11, 2016 at 7:53:01 am

Basically it seems like no matter what I do, as long as I turn up Roughness in the Reflectance channel, or switch on the Bump channel, the light cast on the material will look like flickering fireflies -- see my 1 sec test render

(note the flickering on the wooden box directly under the number 2, and also on the switch. Both materials have Roughness & Bump enabled). The light is emitted via Luminance in the filament's material.

Render settings:

  • Standard renderer (Physical takes too long for animation)

  • no AO

  • no GI

  • Anti-Alias is set to Best

  • Under Layer Sampling, lowered Clamp Secondary to 0.5

  • Under Layer Sampling, Sampling Subdivisions remains default at 4 (I tried increasing this value, but for a value large enough to get rid of the flicker, render time increased so much it's not practical).

  • Even if I set Roughness of the wooden box material to 0% -- keeping Bump only -- the problem persists (see this screencap).

    What am I doing wrong here?

    Return to posts index

    Adam TrachtenbergRe: Roughness/Bump always cause "fireflies"?
    by on Jan 12, 2016 at 12:06:23 am
    Last Edited By Adam Trachtenberg on Jan 12, 2016 at 12:31:41 am

    You might want to give physical renderer another try. This time set the sampling quality to automatic and adjust the roughness noise using the "Bluriness Subdivision (Max)" setting. Then increase the Shading Error Threshold to balance speed/quality (higher % = faster).

    I recommend this video tutorial for an excellent explanation of optimizing the physical render engine:

    Return to posts index

    << PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
    © 2016 All Rights Reserved