MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

How do I make a Landscape Object solid?

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jim Scott
How do I make a Landscape Object solid?
on Dec 7, 2015 at 1:02:41 am

I am trying to make a snow globe using a Landscape Object as the terrain inside, and am using a Boole Object of the hollow globe subtracting the landscape so that the landscape only appears inside the globe. It works as planned, but since the landscape is essentially a thin plane it is not solid, and when viewed from the side there is no material beneath it in the globe. Is there some way to extrude it downward so that the landscape is solid?

Or is there some other way to create a solid terrain inside the globe?

Thanks for your help.



Return to posts index

Adam Trachtenberg
Re: How do I make a Landscape Object solid?
on Dec 7, 2015 at 2:28:07 pm

You could malk the Landscape Object editable. Then go into edge mode and use loop selection with "select boundary loop" enabled. Select the outer edges and extrude them down (you can use the move tool with Cmnd/Ctrl). Finally, go into polygon mode and use Mesh>Create Tools>Close Polygon Hole to create a cap for the bottom.


Return to posts index

Jim Scott
Re: How do I make a Landscape Object solid?
on Dec 7, 2015 at 4:23:48 pm

Thanks Adam,

As I am just a hobbyist with C4D, your suggestion here has taught me much. But while the result of your technique does create an enclosed landscape shape, there is still empty space under the landscape in the area generated by the boole. I suppose it is a natural handicap of Cinema that its 3D objects have only faces and no internal volume - they're not really solid, but hollow - and that's creating my problem.

To try to surmount this difficulty I have created another boole object that only includes the part of the globe that is under the landscape and then applied the same texture as the landscape (snow) so that it will appear solid from the outside view. Now if there was a plugin that created truly solid objects, that would solve my problem easily. But for now I seem to have found a way around it.

Thanks again for all your help.



Return to posts index


Adam Trachtenberg
Re: How do I make a Landscape Object solid?
on Dec 7, 2015 at 11:40:49 pm

Hmm, not sure why it isn't working for you. As long as all the vertices are welded and there are no holes in the mesh Cinema should see it as solid.

Example: 9542_snowglobe.c4d.zip


Return to posts index

Jim Scott
Re: How do I make a Landscape Object solid?
on Dec 7, 2015 at 11:45:07 pm

Thanks again Adam. I am sure it is just operator error on my part. I will take a look at your generously supplied example and see if I can't figure out what I'm doing wrong.



Return to posts index

Jim Scott
Still not working
on Dec 8, 2015 at 2:43:46 am

Ok, Adam, I give up.

I tried to do exactly as you directed, but the end result only has a few small portions of the sphere below the landscape ending up solid.

When you said, "as long as all the vertices are welded," was that another step that you didn't mention in your first reply, or is that taken care of with the other steps?

When I'm done following your directions my landscape looks just like yours but doesn't produce the same result in the boole.

Sorry for my ignorance, and I do very much appreciate the help.



Return to posts index


Brian Jones
Re: Still not working
on Dec 8, 2015 at 3:08:36 am

Adam's file shows it if you turn off the Boole (which I assume you did) - probably have to see your landscape boole (the scene file or just that part of it) to tell what is happening.


Return to posts index

Jim Scott
Re: Still not working
on Dec 8, 2015 at 3:46:53 am

Mine looks just like Adam's does if I turn off the boole. With the boole active, the sections working below the landscape change depending on how many segments the intersecting sphere is given.

Looking over the directions for embedding pictures/files in my posts, I have no idea how to access my "server/service provider account," so I am at a loss as to how to do so.

Thanks for your help.



Return to posts index


Jim Scott
Re: Still not working
on Dec 8, 2015 at 5:44:17 am

Ok, I found something that works, but I don't know why.

If I uncheck High Quality in the Boole Object Properties my landscape will work just fine. Using the landscape that Adam created, this step is unnecessary. His works fine with it either checked or unchecked. Go figure.



Return to posts index


Brian Jones
Re: Still not working
on Dec 8, 2015 at 2:35:38 pm

depending on construction and alignment of parts etc. that is often necessary


Return to posts index

Jim Scott
Re: Still not working
on Dec 8, 2015 at 3:06:33 pm

Thanks Brian.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]