MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Noise Movement, Layer Shader

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Aaron PozzerNoise Movement, Layer Shader
by on Nov 12, 2015 at 7:40:04 pm

hoping someone can confirm this does NOT work for me, and that im not just missing something obvious. At first i could not for the life of me get noise movement to work. After so searching, i found 1 thread where someone mentioned 'make sure "noises" is activated in the viewport options', which i did, and that temporarily solved the problem, since i was in a new test scene. now i can see my noise move when in the viewport when i scrub.

i jump back to my working scene, where i have noise in a layered shader acting as a layer mask for a texture. i want the noise to move over time. it seems when the noise is in a layer shader, the movement does not work. this happens in both r16 and r17. i dont know why putting it in a layer would break the viewport animation, but it does.

the animation is still present if you do a full render, but thats realy tedious when trying to simply set some animation and move on.

is there a solution or workaround im not aware of, or is this a bug? thanks.


Return to posts index

Brian JonesRe: Noise Movement, Layer Shader
by on Nov 12, 2015 at 8:15:23 pm

in the material's Editor tab make sure Animate Preview is checked - the apparent scale of the noise is wrong (very similar to the scale problems if you turn Options/Noises off) but it does animate


Return to posts index

Aaron PozzerRe: Noise Movement, Layer Shader
by on Nov 12, 2015 at 8:24:24 pm

thank for the response brian. i had tried with and without the animate preview turned on before i made my initial post. in my case it doesnt seem to help. the noise evolution works, but not the movement.


Return to posts index


Brian JonesRe: Noise Movement, Layer Shader
by on Nov 12, 2015 at 8:26:59 pm

can you post the shader (even in an otherwise empty file) it would interesting to see what breaks it - I just tried a fairly simple layer shader


Return to posts index

Aaron PozzerRe: Noise Movement, Layer Shader
by on Nov 12, 2015 at 10:31:10 pm
Last Edited By Aaron Pozzer on Nov 12, 2015 at 10:31:38 pm

yup, here you go (r17)...

https://www.dropbox.com/s/u5bv2ig56exx4r6/layerNoise.c4d?dl=0

i made a noise, added movement, applied to cube, scrubbed, worked. duplicated cube, duplicated material, renamed, simply clicked the texture slot noise and switched to layered, and now its broken.


Return to posts index

Brian JonesRe: Noise Movement, Layer Shader
by on Nov 13, 2015 at 12:34:41 am

ah, you can animate the noise but you can't move the noise (at least not in the viewport) in a Layer. I don't see anything about Layer limitations in the help. Put a report into Maxon, either they don't know or there's a reason


Return to posts index


Aaron PozzerRe: Noise Movement, Layer Shader
by on Nov 13, 2015 at 12:38:18 am

k, just wanted to make sure i wasnt missing something simple. seems like an obvious oversight on their part.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]