MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

card attached to balloon string through xpresso won't fix on string point? (file included)

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel De Silva
card attached to balloon string through xpresso won't fix on string point? (file included)
on Nov 12, 2015 at 12:59:22 pm

Hey guys,

I need some fast help if possible!

As can see attached in the scene, I have a card attached to a balloon string using xpresso, string is dynamic.

When still the card remains intact with the string end point, however when moving it moves itself a few places down for reasons which I can't seem to see?

Anyone have any solutions?

9451_forsolve.c4d.zip

Thanks!

Dan.


Return to posts index

Cassius Marques
Re: card attached to balloon string through xpresso won't fix on string point? (file included)
on Nov 12, 2015 at 1:25:24 pm

Just baking the dynamics then caching the spline dinamycs seems to solve the issue. Have you tried that?

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Daniel De Silva
Re: card attached to balloon string through xpresso won't fix on string point? (file included)
on Nov 12, 2015 at 2:23:48 pm

Genuis! I'm new to dynamics so wasn't sure what the issue was, speaking of what was the actual issue here?

Thanks,

Dan.


Return to posts index


Brian Jones
Re: card attached to balloon string through xpresso won't fix on string point? (file included)
on Nov 12, 2015 at 3:07:04 pm

Priority of the XPresso is too low (early) it's getting evaluated first - it's moving the tag to where the string is at the calculation phase of the frame - then the balloon gets moved by the dynamics later in the calculation phase, then it renders so the tag is always a frame behind. If you increase the Xpresso priority to a higher value (calculates later) than the dynamics the xpression will calculate after the dynamics and follow the balloon. Dynamics priority is Generators +400 so the XPresso has to be Generators +401 or higher.


Return to posts index

Daniel De Silva
Re: card attached to balloon string through xpresso won't fix on string point? (file included)
on Nov 16, 2015 at 12:11:55 pm

amazing thanks so much this worked also!

I have a follow up question with another issue I am experiencing, after the simulation ends, from frame 300+ I have a slight jitter on my spline dynamics that I don't want in the scene as the camera will be in on a close up to read text on the card, how can I get rid of ths?

I've attached the files for you to see what I mean!

9460_balloonjitter.c4d.zip

Thanks!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]