MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

mograph cloner and mesh deformer

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
crasse deux
mograph cloner and mesh deformer
on Sep 17, 2015 at 12:59:01 pm

Hi there !

I was wondering if there is a way to clone a mesh with a mesh deformer ?

here is my plan :
I got a quite complex mesh, I want to clone it and clones to behave as a soft bodies.

Obviously putting the soft body tag directly on the mesh isn't a good idea at all (I want to make something like 30 clones) so I used a mesh deformer and a cube (4x4x4 division) with a soft body tag as a box, and it works like a charm until I try to put this setup in my cloner.

first I put everything (soft body cube/box, the mesh + mesh deformer) into a null, and then put this null in my cloner object.
Everything is cloned right, but then I hit play and the result is that the cloned meshes aren't linked anymore to their respective deformer boxes
-> the cloned softbody cubes/boxes fall rightly on the floor, but the meshes stay in the air, at their starting point, as if the mesh deformer wasn't working anymore.

is there a way to make this setup work (cloning a mesh deformed object) ?


Return to posts index

Brian Jones
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 3:51:46 pm

Cloner (Render Instances = Off)
--Cage (with Soft Body Tag)
----Object
------Mesh Deformer


Return to posts index

crasse deux
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 4:03:10 pm

Hi !

thanks for the answer !

unfortunately i didn't get it to work this way either (by putting the object+mesh deformer inside the cage object, and not under, as I did before), but it get closer !

This time cloned objects fall with the cloned cage, so the rigid body part now works, but they aren't deformed on collision according their cages, so the soft body part didn't seems to work.

maybe i'm missing something,

here is a small test scene with that setup, if you have time to look at it, that would be awesome ! i'm sure i'm doing something wrong but i can't find what...

9262_softbodyclonetest.c4d.zip


Return to posts index


crasse deux
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 4:20:49 pm

in fact I said a mistake, the rigid body part doesn't work either, balls are falling within the cages because they are now inside cages (in the hierarchy), so the mesh deformer still isn't working within the cloner. I didn't noticed it before, but it can't initialise (initialisation use 0 KB of memory when it's in the cloner, outside the cloner initialisation store around 200 KB of data).


Return to posts index

Brian Jones
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 4:40:41 pm

the null needs to go and it helps to align the cage and object before you start and initialize the mesh deformer - this appears to work for me, am I missing something?

9263_softbodyclonetestfix.c4d.zip


Return to posts index

crasse deux
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 4:54:39 pm

thanks for the answer !

I think the problem is still there, if you put the object setup (cage + sphere + mesh deformer) outside the cloner and hit play, the ball is noticeably "flubby" when it hit the floor, due to the soft body deformer from the cage/cube (so it works)

but when you put it back in the cloner, the cages (now cloned) still fall and are deformed by the collision to the floor (soft body tag works), but the spheres inside aren't. it's like the mesh deformer doesn't affect them anymore.

maybe the mesh deformer can't be cloned ?


Return to posts index


Brian Jones
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 5:16:21 pm

I see, I was missing it in the lines display... had to zoom way in.


Return to posts index

crasse deux
Re: mograph cloner and mesh deformer
on Sep 17, 2015 at 5:47:22 pm

So there is no way to clone it properly ?

i've googled this a lot and didn't found anything about it, I've already cloned mesh deformed objects, but this was with baked animation (and it worked, using instance clones), So maybe cloning a mesh deformed object dynamicly deformed isn't a possibility.

I'll try find another way cause i definitely can't put my soft body tag directly on my objects and clone them, C4d totally freeze while previewing the animation.

If I finf something interesting, I'll report it here, this may interest other folks !


Return to posts index

Christoph Wolf
Re: mograph cloner and mesh deformer
on Oct 7, 2017 at 11:53:46 am

Hi, I got it to soft body cloner to work but somehow I the copies are turned invisible now, and wherever I aapply the texture / material I can only see the meshes...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]