MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

2 thinking particles emitters align to spline

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
petcov petru
2 thinking particles emitters align to spline
on Aug 8, 2015 at 4:01:11 pm

i have this scene 9121_tpfollowspline.c4d.zip but if i bring the emitters close to each other particles(lines) from one emitter start to go in the opposite direction,like they influence their emitting forces between them

and i don't understand why is that,how are they working,are some forces here? the only thing that has an effect it seems to be point velocity in TP Follow Spline Null but i can't get it to function right


Return to posts index

Brian Jones
Re: 2 thinking particles emitters align to spline
on Aug 8, 2015 at 6:56:33 pm

both emitters and Follow Splines are using 'All' as the group since no group is chosen so when the one spline gets closer than the Trigger Distance to the other spline whichever is on top in the OM takes over. You have to use different groups for each emitter/follow/spline combo


Return to posts index

petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 8, 2015 at 8:53:54 pm
Last Edited By petcov petru on Aug 8, 2015 at 8:56:06 pm

Ok,thank you very much...i will see what can i do though i don't know how,because i'm absolute beginner with thinking particles(i've made this scene with the presets from content browser)


Return to posts index


petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 10, 2015 at 12:25:50 pm

i manage to do that but now i can't align it to spline anymore
and for the life of me i can't understand what i have to do

9126_tpfollowspline.c4d.zip


Return to posts index

Brian Jones
Re: 2 thinking particles emitters align to spline
on Aug 11, 2015 at 2:32:11 am

this is simplified but this is all that's necessary - important bits are
- direction of the splines (you can tell in point mode with a spline selected)
- take a look at where the spline groups are used in the emitters and the follow splines

It looks like you been in the Thinking Particles Settings dialog which is good as that's the place to make new groups and drag them to the places in the emitters (xpresso really) where they are used.

9129_tpfollowsplinefix.c4d.zip


Return to posts index

petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 11, 2015 at 9:33:16 am

yes,thanks again very much...in the meantime i succeeded to decipher it

Thank You!


Return to posts index


petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 11, 2015 at 10:04:06 am

just one more question :),i want that particles to travel with much higher speed but when i increase it they don't align to spline perfectly anymore.

i played with the TP Follow Spline settings and tracer settings but can't get it right -
9131_tpfollowspline2.c4d.zip

can be done something about it?


Return to posts index

Brian Jones
Re: 2 thinking particles emitters align to spline
on Aug 11, 2015 at 9:22:51 pm

I don't know if you can, TP doesn't do subframe calculations (you can sort of do subframe emission but not subframe calculations) so the particles are moving that far in between frames and can only adjust after.


Return to posts index

petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 13, 2015 at 9:21:04 am
Last Edited By petcov petru on Aug 13, 2015 at 9:21:40 am

i don't really understand what you mean that you can adjust that only after.

and than what can i do,isn't there other solution?

in fact this was supposed to be some kind of car light trails and i was thinking if it's doable with camera settings with real lights and motion blur like you do a timelapse car lights trails in real world


Return to posts index


Brian Jones
Re: 2 thinking particles emitters align to spline
on Aug 13, 2015 at 3:23:58 pm

the particles can only adjust after they overshoot in the time gap from one frame to the next. TP does not do sub-frame calculations so at that speed it overshoots the corner in the spline between frames and has to adjust back to the spline over the next bunch of frames.
X-Particles does subframe calculations so it should work if you had x-particles.
The other possibility is to use a number of splines with sweeps on them and use textures moving along the sweep to fake the motion


Return to posts index

petcov petru
Re: 2 thinking particles emitters align to spline
on Aug 13, 2015 at 7:45:04 pm
Last Edited By petcov petru on Aug 13, 2015 at 7:50:38 pm

i don't know if it's really a sub-frame calculations problem,at least i saw a solution to do sub-frame from this tutorial http://helloluxx.com/tutorials/cinema4d-2/cinema4d-thinking-particles/sub-f......please tell me if this this could solve my problem

but however someone told me(in fact at least so he thought) that the problem is the limited maximum value of precision from TP Follow Spline to 10000.but even if you modify that and crank up the precision above 10000 it doesn't matter(i don't really understand why is that)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]