MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Weird Flicker in Ice Texture

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Courtis Merry
Weird Flicker in Ice Texture
on Apr 9, 2015 at 7:29:58 pm

Hey guys,
I have an animation of some ice crumbling and falling to ground. When the camera moves, and even when it stops, I get a weird flicker in the texture of the ice chunks. Any idea what might be causing this and what I could do to correct it? Here's a link to the current render: https://copy.com/NnPLsQHG6SgmM319 It stops flickering at the end because there is a freeze frame. Any help would be appreciated! Thanks.


Return to posts index

Brian Jones
Re: Weird Flicker in Ice Texture
on Apr 9, 2015 at 9:01:48 pm

is AO on? Another strong possibility is the the Ray Depth in Render Settings/Options - if the depth is too low with all those transparent chunks on top of each other there might be black as the ray depth is exceeded


Return to posts index

Courtis Merry
Re: Weird Flicker in Ice Texture
on Apr 9, 2015 at 9:10:24 pm

AO is definitely on. I just did a test render without it and it did the same, just with bad looking ice. My ray depth is set to 15, any suggestion how high to put it?


Return to posts index


Brian Jones
Re: Weird Flicker in Ice Texture
on Apr 9, 2015 at 9:13:17 pm

you just have to make a guess depending on the number of chunks flying around and how many layers a render ray has to go through. Try doubling it to 30 and see if it changes.


Return to posts index

Courtis Merry
Re: Weird Flicker in Ice Texture
on Apr 9, 2015 at 9:33:04 pm

Got it at 30 and it's still doing it. Attached are three stills (maybe, haven't ever added stills to this site), does the anti aliasing filter being at "Gauss (animation)" instead of "Cubic (still image)" have anything to do with it?




Return to posts index

Brian Jones
Re: Weird Flicker in Ice Texture
on Apr 10, 2015 at 12:39:39 am
Last Edited By Brian Jones on Apr 10, 2015 at 12:45:09 am

ok had a chance to watch the clip at home and no, it can't be ray depth as there is one piece on the floor on the left which is directly on the floor which is flickering. As you said turning off AO doesn't change it without seeing the scene file I now have to guess GI but you haven't disabled disabled GI in the transparent textures (Illumination tab) - transparent textures usually contribute and receive essentially nothing with GI in a render but can slow render down and maybe cause problems. Other than that I'd have to see the file unless wiser heads know something else.


Return to posts index


Courtis Merry
Re: Weird Flicker in Ice Texture
on Apr 10, 2015 at 3:31:21 pm

So far I've been able to determine that it's something with the polygons themselves. I've turned off all the lighting and removed the textures and the pieces still flicker in C4D (didn't do a test render of it). I'm just not advanced enough at this point to determine what exactly it is.. Here's a link to the project with assets if you wouldn't mind looking at it. I apologize for the size, the floor is a video. https://copy.com/IRnRImnwJPIkmBtJ


Return to posts index

Ehsan tabasi
Re: Weird Flicker in Ice Texture
on Apr 10, 2015 at 8:22:25 pm

Hi
I Don't now if i am right or not But i think i had the same problem
by flickering before and i solve it when i use physical render instead of standard .

http://www.Hezarchehreh.com


Return to posts index

Brian Jones
Re: Weird Flicker in Ice Texture
on Apr 11, 2015 at 4:07:17 am

the pieces of the 'E' penetrate the floor but the I and C do so only a bit - as all are cached I removed the cache the the E behaves like the others now - in a test in the viewport there does seem to be some residual motion of the chunks, that too might be the problem. Doing a test render now (won't see it until later) but if it's still flickering now the next test is to stop the pieces quicker (friction or restitution lifetime perhaps)


Return to posts index


Brian Jones
Re: Weird Flicker in Ice Texture
on Apr 12, 2015 at 3:17:50 am

I put an invisible collider floor 1cm above the visible floor you have now and let the pieces collide with that (wasn't having much success with Margin etc.) and that stopped most of it. There are still couple flickers after that between a couple pieces but at least none with the floor that I can see.


Return to posts index

Courtis Merry
Re: Weird Flicker in Ice Texture
on Apr 12, 2015 at 5:20:04 pm

I just did the same (invisible floor). I also put compositing tags on the chunks and turned the anti-aliasing up on just those, that seems to help tremendously! I think a combination of the two should solve the problem. As for the stray bouncing pieces.. I am aware of them. Just kind of ignoring them.. The big thing was to make the flicker stop, I will deal with the bouncing pieces as they come. Thank you all for your help and input!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]