MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Fracture + Rigid body + Collider body = failure??..

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Esther Mitchell
Fracture + Rigid body + Collider body = failure??..
on Oct 8, 2014 at 6:35:11 am

Okay, so I'm trying to create a crash scene. I created the ship, I've disconnected the polygon faces (so it shatters), I have placed this in a Fracture with the Object Mode set to Explode Segments (so each piece is individually falling). I then put a Rigid body tag on the Fracture. I tested the scene out so it would fall on a generated landscape with a Collider body tag. It worked really well.

BUT the real problem is when I put it on to a generated landscape I 'current state to objected' so I could edit it (sculpt, thats not the problem though as when I take the tag off it doesn't change anything). When this edited landscape has a Collider body tag (just the basic one without any setting changes), the fracture debris float up, WITHOUT coming into contact with the landscape. It doesn't seem to matter where they are in relation to each other, if that landscape has a Collider body tag, the fractured objects float up.

I'm not sure what is wrong with my landscape, and I really need both objects.. let me know if you need screen shots or the file, and thanks in advance!


Return to posts index

Brian Jones
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 8, 2014 at 2:19:42 pm

what is Collision/Shape set to in the collider body tag?


Return to posts index

Esther Mitchell
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 9, 2014 at 11:17:02 pm

Collider body tag is just the automatic settings Dynamic: Off , Trigger: Immediately , Transition Time: 60F. I found that if I put the landscape which has the collision tag (that makes the ship float) in a cloner that the ship doesn't float away, but it then goes through the landscape (tried putting the collision tag on the cloner and had the same effect).


Return to posts index


Brian Jones
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 9, 2014 at 11:43:06 pm

those are the settings in the collider tag's Dynamic tab but what are the settings in the Collision tab (just to the right)? The Shape setting there sounds like it's on Automatic but it should probably be Static Mesh - or are you working with a much older version of C4D?


Return to posts index

Esther Mitchell
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 10, 2014 at 2:01:25 am
Last Edited By Esther Mitchell on Oct 10, 2014 at 2:04:36 am

Hope the image uploads, thats what its on. I'm also using Cinema 4D Studio 15. But the bounce (50%) shouldn't come into it if it doesn't come into contact?

Settings for collision
Inherit Tag: None
Individual elements: Off
Self Collisions (tick)
Shape: Automatic
Size Increment: 0cm
Use (no tick)
Keep Soft Body Shape (tick)
Bounce: 50%
Friction: 30%
Collision Noise: 0.5%


Return to posts index


Brian Jones
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 10, 2014 at 2:03:39 am

yes, Shape is set to Automatic - try changing it to Static Mesh


Return to posts index


Esther Mitchell
Re: Fracture + Rigid body + Collider body = failure??..
on Oct 10, 2014 at 2:20:58 am

Thank you, that completely fixed it! you sir are a genius


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]