MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Problems with Phong and Connect Objects

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Hayden Martin
Problems with Phong and Connect Objects
on Oct 1, 2014 at 6:29:58 pm

Hi Guys

I'm having a very hard time fixing these bad edges on my animated robot and the deadline is getting close!

I have tried adjusting the Phong angles but they are still revealing the bad edges, and even creating artefacts.

I've even tried Hypernurbing them objects but then I find out that they're broken into groups rather than being fully connected. This is a real problem as the elements are already broken up, and using Connect amongst parent and child objects sometime makes the whole robot disappear.

How do I connect these surfaces and how do I smoothen them out?

It would be incredibly helpful if somebody could take a look and provide me with a fixed scene!

Thanks so much CC

8054_robot.c4d.zip


Return to posts index

Adam Trachtenberg
Re: Problems with Phong and Connect Objects
on Oct 1, 2014 at 11:40:07 pm

That is some messed up geometry. Every object has a bazillion disconnected points, polygon normals are reversed, naked edges....

But when I optimize to get rid of the extra points it makes the shading problems 100X worse. It almost looks like the objects are using normals tags, but I don't see any.

What program did you use to create the model?


Return to posts index

Hayden Martin
Re: Problems with Phong and Connect Objects
on Oct 2, 2014 at 12:48:23 am

Babel3D's online CAD converter. I have the original CAD file in .STP but could not get hold of a system with the right software to convert it to an OBJ with good geometry!

It would be incredibly helpful if I could get the file converted from .STP SAFELY haha

Here's the SolidWorks file...
8057_robot.stp.zip

I would be so grateful if you could convert this for me, ready to animate


Return to posts index


Brian Jones
Re: Problems with Phong and Connect Objects
on Oct 2, 2014 at 12:37:04 am

Adam said it, seriously messed. You can optimize and take out 1.2 million unconnected points if you only check Unused Points in the Optimize tool which only removes the extra points without welding anything which, as Adam said, only makes things worse.
After that turn on Angle Limit in the Phong tag and reduce the Phong Angle down (low but not too low) 28° looked ok in quick testing.
Some polys don't get fixed by that and you'll probably have to remove them and replace them with the Create Polygon tool if they show too much


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]