MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

How to get rid of these artifacts

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ryan Paterson
How to get rid of these artifacts
on Aug 29, 2014 at 11:25:51 pm

This image has some strange artifacts in the reflections, which are definitely polygon-related but I can't figure out how to get rid of them. I have subdivided which didnt help (actually made it worse with some settings) It's weird if I subdivide by 1 it looks good, but if I go to 2 it gets more noticeable. Tried adjusting the samples in the blurry reflections, didn't do anything.

Is there some kind of like "reflection resolution" setting or something? Or just really any ideas on how to get rid of this. Thanks!



Return to posts index

Brian Jones
Re: How to get rid of these artifacts
on Aug 29, 2014 at 11:27:41 pm

have you tried adjusting the Phong Angle in the Phong tag?


Return to posts index

Ryan Paterson
Re: How to get rid of these artifacts
on Aug 29, 2014 at 11:48:47 pm

Ugh I was REALLY hoping that would work but sadly, no. Good tip tho!


Return to posts index


Brian Jones
Re: How to get rid of these artifacts
on Aug 30, 2014 at 12:06:02 am

got to know more about the scene then. Which renderer, what lights (if any) GI, AO etc. might it be specular rather than reflection we are looking at? what is it reflecting - etc. etc. etc. It's hard to tell without the scene file.


Return to posts index

Adam Trachtenberg
Re: How to get rid of these artifacts
on Aug 30, 2014 at 4:03:09 am

Also, where did the model come from? Does it have a normals tag? Can we see a wireframe?


Return to posts index

Ryan Paterson
Re: How to get rid of these artifacts
on Aug 30, 2014 at 7:42:20 am

Have at it!

7923_skull.c4d.zip


Return to posts index


Brian Murphy
Re: How to get rid of these artifacts
on Aug 30, 2014 at 2:38:02 pm

This may be over simplifying it and you may have tried it already but I get artefacts that look similar when the shadow maps in my lights are not a high enough resolution.

If not that, is your reflection map a high enough resolution - looks like the reflection is pixelated.

Third, have you optimised all points on the model?



Return to posts index

Brian Jones
Re: How to get rid of these artifacts
on Aug 30, 2014 at 2:57:12 pm
Last Edited By Brian Jones on Aug 30, 2014 at 3:09:54 pm

I am not seeing the artifacts here *but* I don't have the lighting kit pro. I do have the hdri kit though so I turned off the lighting kit parts (due to their textures being missing) but I left the area lights on (buried in the light kit parts). No artifacts. I have to guess that the image called Stripes.jpg, that C4D tells me is missing, is responsible for your stripey artifacts, at least with what I am seeing.
BTW this renders _way_ faster in the physical renderer even with the settings turned up a bit to match the standard render (4 sec vs 57 secs here)


Return to posts index

Emir Bojorquez
Re: How to get rid of these artifacts
on Aug 30, 2014 at 5:34:01 pm
Last Edited By Emir Bojorquez on Sep 9, 2014 at 12:58:12 am



As you can see in the first image, that is caused by some shading issues and geometry of your skull in combination with the Subdivision Surface.

To solve this:

1.- Delete the Normal Tag that the Head and Jaw has (the one that looks like chessboard).
2.- Select the Head and the Jaw, then go to polygon Mode and select all the Polygons (Ctrl + A).
3.- Right Click and move the mouse to Untriangle and click over THE GEAR NEXT TO THIS COMMAND.
4.- inside the Untriangle Command Menu increase the Angle to 50.
5.- activate the Phong tag and increase to 60.



Good Luck

Imagination is the best tool...


Return to posts index


Ryan Paterson
Re: How to get rid of these artifacts
on Aug 30, 2014 at 7:04:29 pm

Worked like a charm! Thanks so much. So basically what I just did was simplify the geometry and smooth out the angles? Can I ask what made you realize you needed to un-triangulate? I'm really trying to learn as much about 3D as possible, and it's always these little technical details that seem to make all the difference.

Really appreciate you taking the time to help, thanks again :)


Return to posts index

Emir Bojorquez
Re: How to get rid of these artifacts
on Aug 30, 2014 at 7:18:24 pm

triangles usually produce anomalies when you smooth your models using subdivision Surface, that is because of the uneven amount of vertices, that also happens with N-gons.



Good Luck

Imagination is the best tool...


Return to posts index

Steve Roberts
Re: How to get rid of these artifacts
on Sep 8, 2014 at 4:32:29 pm

Emir, I was having a similar problem rendering a purchased model with GI, so I thought I'd try your solution. Perfect. I'll bookmark it for the future.

Thanks!
Steve



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]