MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Clone alignment on Text Spline

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ryan Kehn
Clone alignment on Text Spline
on Jun 19, 2014 at 9:58:38 pm

Totally stumped...

Hey all, trying to clone some objects along a text spline. As you can see in the screen shot, every third letter or so, the objects clone completely upside down. Can anyone provide some thoughts on what may be causing this? I've played around with most every setting i can think of with no dice.



Thanks in advance!

Ryan Kehn
Senior Designer
VWBSN


Return to posts index

Brian Jones
Re: Clone alignment on Text Spline
on Jun 19, 2014 at 10:53:02 pm

the 'closed loop' letters (the ones with holes - O and D) are the problems, because they both contain two segments to the spline making them up the normals are likely backward. Try Reverse Sequence on the splines for those letters.


Return to posts index

Ryan Kehn
Re: Clone alignment on Text Spline
on Jun 21, 2014 at 2:26:47 pm

Brian,

Thanks for the reply, I haven't been able to get back to that project for the last couple of days. I tried what you suggested, but no dice. All reverse sequence did was change the directio in which the object was cloned, but it's still upside down. Also, it's not just the closed loop letters, it's happening to the T as well.

I was hoping to keep this as procedural as possible. The screenshot I sent you had everything mapped to the original text object spline (hadn't made the spline editable yet) and used a mograph selection to blank out clones in the "holes" of text. It's not a huge problem to just duplicate the spline and make editable if need be, but right now, netiher way is working correctly:/

Any other suggestions?

Thanks!

Ryan Kehn
Senior Designer
VWBSN


Return to posts index


Adam Trachtenberg
Re: Clone alignment on Text Spline
on Jun 21, 2014 at 5:24:16 pm

Try duplicating the text spline, offsetting it in Z, and using it as a rail spline in the cloner.


Return to posts index

Brian Jones
Re: Clone alignment on Text Spline
on Jun 21, 2014 at 5:28:36 pm

Definitely, I've just been doing some simple tests with a cloned cone so I can see clearly which direction they point when cloned to a text spline. The direction they point on each letter segment depends on the font used, so the internal construction of the each font is going to dictate the direction the clones point. Making it work is much easier with a rail spline than trying to take the individual bits apart.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]