MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Cineware Camera slightly off in After Effects CC

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Dustin Bowser
Cineware Camera slightly off in After Effects CC
on Feb 20, 2014 at 10:00:03 pm

I've got a scene from C4D R15.008 that I'm trying to extract some 3D data in After Effects CC 12.2.1.5.

I've rendered out my passes as image sequences for compositing, but I'm trying to get a few lights and a 3D plane for some additional composite elements of smoke and whatnot in 3D space.

When I bring my C4D scene into After Effects, everything lines up. I've brought in my rendered passes to double check the alignment over the draft 3D Cineware preview.

The problem is, when I try to extract the 3D data, the camera changes slightly. I can't quite tell if it's changing position, or changing field of view or something, but my lights and other 3D elements are slightly off when viewed through my proper camera. When I enable the Extracted camera that I'm trying to use, and then select 'Comp Camera' in the Cineware settings, everything changes position slightly. My 3D objects line up properly with the underlying draft geometry, but now everything is slightly off from my rendered image sequences.

I've double checked that the focal length, angle of view, etc.... is all the same as in C4D and it is. My keyframes from the camera animation are all baked, so that should be a problem. My scene units are in cm.

I can't figure out what is causing the shift, because it's pretty subtle, but it's significant enough to make it unusable.

Is there some gotcha with Cineware that someone out there knows about? Or any particular things to double check in my scene to make sure they aren't translating funny?

Any help is appreciated. Thanks!


Return to posts index

Damian Ineichen
Re: Cineware Camera slightly off in After Effects CC
on Sep 23, 2016 at 9:50:32 pm

Hi Dustin

I have the same issue. Did you find a solution for that?

Damian


Return to posts index

Tom Munday
Re: Cineware Camera slightly off in After Effects CC
on Oct 20, 2016 at 2:55:55 pm

I've got exactly the same problem

To check it I've exported the cam to afx, brought it back into C4D and compared it to the original - seems to be the rotation is ever so slightly different which puts things ever so slightly out of sync

No solution as yet - let me know if you find anything, it's rather important these line up!


Return to posts index


Rob McDougall
Re: Cineware Camera slightly off in After Effects CC
on Jan 5, 2017 at 8:10:57 pm

This could be a frame rate mismatch. Check your project settings and render settings in C4D match you frame rate in AFX.


Return to posts index

Steve Earthling
Re: Cineware Camera slightly off in After Effects CC
on Feb 3, 2017 at 8:18:05 pm

Solution: Camera off during import or when Changing comp size

Because the problem only appears on the in-between frames this is evidence that After Effects has a different interpolation method between keyframes which makes sense, however the keyframes are a perfect match. An easy solution is to bake your animation frames within Cinema 4D before saving out your file. Just select your camera object, ensure all properties are highlighted in the Dopesheet animation window, then under Function in the menu you can bake the animation for that object. Baking creates keyframes on every frame so there is nothing for After Effects to interpolate. This will fix this problem.

However I came across another camera alignment problem after changing my comp size. I made the mistake of starting my work with a 1280 x 720 comp size. When I was ready for final render I had to up size it to 1920 x 1080 and noticed the camera was off again. The keyframes were not sliding this time, it was shifted off center on every frame now as if zoomed out. I first double checked that my cinema 4d render dimensions were saved as 1920 and that didn't work. It was still wanting to adjust it to 1280 for some reason within After Effects. I realized the fix was under the camera settings that I had already been using in After Effects. Uncollapse the settings for the camera layer, and adjust the Zoom pixels to match your comp size. This fixed it instantly, and you want to make sure this number always correlates to your comp size. I hope this helps some of you folks, it was a lifesaver for me to figure all this out!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]