MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

R15 GI Flickering

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris PettitR15 GI Flickering
by on Jan 23, 2014 at 6:48:26 pm

Hi.

I've been very impressed with the improvements to the GI render engine in C4D R15. Until today.

First true complex scene with camera animation rendered using the new GI - I now have flickering again (just like the bad old days). In the past (R14) I used the Physical Renderer, leveraging the indirect illumination option in the PR settings tab, bypassing the lengthy prepasses necessary with standard GI to avoid flickering in the shadows.

But for some reason, Maxon got rid of the IL settings in R15 (Wow), so now we're back to using GI, albeit much improved. But the options for Camera and full Animation seem to be removed, so I'm now getting flickering in the shadows, with no clear options to reduce like the prepasses of old.

I used Irradiance Cache for primary, and Light Mapping for secondary, with all fairly high settings for samples, no good. I tried a series of different settings based on other peoples posts with the same problems. Nothing seems to work.

Anyone successfully found a solution to this issue that doesn't involve prohibitive render times? I really thought these types of issues were a thing of the past. Thanks in advance.


Return to posts index

Adam TrachtenbergRe: R15 GI Flickering
by on Jan 23, 2014 at 7:19:02 pm

The GI in R14's physical render settings was nothing more than QMC, so if you want the same result ... use QMC. Unfortunately the other option is to bump up the cache settings and do a bunch of test renders.


Return to posts index

Chris PettitRe: R15 GI Flickering
by on Jan 23, 2014 at 7:34:00 pm

[Adam Trachtenberg] "The GI in R14's physical render settings was nothing more than QMC, so if you want the same result ... use QMC. "

Thanks Adam, that's what someone else said as well, but when I tried rendering with QMC the render times were wildly longer that I remember IL being. In R14 the render times were tolerable, with QMC it seems prohibitive. Is it possible that it works the same but is slower? Or maybe its that there are so many more settings for QMC, my settings are not correctly applied to get back to the simplicity of IL. I'll work on it.

[Adam Trachtenberg] "Unfortunately the other option is to bump up the cache settings and do a bunch of test renders."

Is the source of the flickering most likely resident in cache settings? If that's the area to focus on, I'll start new renders and see. Thanks so much!


Return to posts index


Adam TrachtenbergRe: R15 GI Flickering
by on Jan 23, 2014 at 8:40:13 pm

Okay, I've done some testing and I think I've figured it out. Basically, the old indirect illumination from physical render was relatively fast because it was using a low sample count -- much lower than the "low" setting in the QMC default.

I find I can get a slightly better (less grainy) result a little faster using the following settings:

Primary method: QMC
Secondary method: Radiosity maps

Custom sample count: 24
Radiosity map sample density: 50%

Everything else at default.

Give it a shot and let me know what you find.


Return to posts index


Chris PettitRe: R15 GI Flickering
by on Jan 23, 2014 at 9:40:33 pm
Last Edited By Chris Pettit on Jan 23, 2014 at 10:22:42 pm

Spectacular Adam!

Not only is it rendering very fast, faster than r14, I'm seeing less noise. Very clean render, and of course no flicker. Can't thank you enough for your time and expertise.

I also discovered that your previous input regarding cache settings also produced good result when using the Irradiance Cache / Light Mapping method. I increased record density to high (from medium), and smoothing to 100% (from 50%). This produced largely flicker free renders with a moderate increase in render times.

But the QMC method appears even faster, and operates just like IL in 14.

Thanks again for your help, my guess is this will help others who are making the transition from R14 to R15!


Return to posts index

Adam TrachtenbergRe: R15 GI Flickering
by on Jan 24, 2014 at 2:12:01 am

Glad I could help. Benefits me, too, as I wasn't paying enough attention to QMC.


Return to posts index


Jia Jia WangRe: R15 GI Flickering
by on Dec 6, 2015 at 11:21:37 pm

Thank you so much!!!


Return to posts index

Arvin BautistaRe: R15 GI Flickering
by on Mar 8, 2014 at 9:52:23 pm

I just wanted to reply to this and thank Adam for his suggestion. My renders are flicker free and rendering even faster than the default setting.

Arvin Bautista
Greasy Pig Studios
Los Angeles, CA
http://www.greasypigstudios.com


Return to posts index

Spencer TweedRe: R15 GI Flickering
by on Aug 4, 2016 at 10:55:29 pm

Wow, impressive! I just tried these settings out on a file that I had with a lot of flickering (HDRI in sky and self-illuminated materials) and it's totally buttery smooth. I've never seen GI not flicker without pre-calculations at render times like this! And I normally work in 3DS Max and Vray. Cinema 4D continues to impress!

- Spencer


Return to posts index


Darby EdelenRe: R15 GI Flickering
by on Jan 24, 2014 at 4:22:55 am

Looks like Adam already has you covered on the QMC front :) I'll just add that the Sample Count in GI is directly related to the Indirect Illumination sampling subdivisions in the previous Physical Renderer options. The number of samples for a given pixel was equal to the square of the subdivisions in R13/14. So If you entered a value of 4 subdivisions in the Indirect Illumination tab this was equivalent to 4 * 4 or 16 samples in QMC.

I'm not sure if you were saying that your animation consists only of camera animation but if so the settings you'd want to change are on the "Cache Files" tab of the GI settings. Disabling the "Full Animation Mode" checkbox will render the caches as a Camera Animation.

The new Light Mapping GI mode is a good alternative/addition to Radiosity Maps. You can still "Build Radiosity Maps" through Light Mapping to speed up QMC or IR calculation but you get the added benefit of many many more secondary light bounces. On the downside light mapping can sometimes introduce subtle splotchy artifacts or softness in shadows so settings there may need to be tweaked as well. The documentation goes over this really well. Also if you're doing camera animation (and only if so) you'd want to enable "Use Camera Path" in the Light Mapping settings.

Darby Edelen


Return to posts index

Chris PettitRe: R15 GI Flickering
by on Jan 24, 2014 at 1:53:34 pm

Thanks Darby for all the additional information! Very helpful.

I got a little lazy I think with R14. IL was a quick and fairly easy solution, I need to re-do my homework a bit now in R15

Thanks again


Return to posts index

Jason ClydeRe: R15 GI Flickering
by on Jan 28, 2015 at 1:04:50 am

Apologies for unearthing an old thread, but I'm having similar issues... I bumped up the IC, and when I cache my IC, LM, and AO, I still get extremely long render times with team render. I'm only doing a camera animation, so no moving objects. It's like the caches aren't even being used by the team render clients. Anybody have any idea what is going on here?

Thanks!


Return to posts index


mariano moscuzzaRe: R15 GI Flickering
by on May 6, 2016 at 4:05:37 pm

[Darby Edelen] "I'm not sure if you were saying that your animation consists only of camera animation but if so the settings you'd want to change are on the "Cache Files" tab of the GI settings. Disabling the "Full Animation Mode" checkbox will render the caches as a Camera Animation."

Thank you so much Darby! It was really helpfull !


Return to posts index

Ben LewisRe: R15 GI Flickering
by on Jun 10, 2016 at 2:33:14 pm

Great posts, thanks! Im using R17 but having the same issues in the crevices of my gold lettering. These have proved really useful tips!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]