MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Strange Behaviour - Ambient Occlusion On Hair Material Channel

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Alex ZetaStrange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 1, 2013 at 10:49:17 pm

Hi,
trying to create grass for a garden design, I just discovered a strange behaviour of ambient occlusion shader when applied to, for example, hair density channel.

When i move/scale the plane where hair grows, it seems that hair distribution doesn't refresh..
See these two pictures (plane is also textured with ambient occlusion on color channel with gradient colors from red to blue, just to show that AO map applied to the plane is correct):

First:


Second:


Could it be a bug or there is some rule that I am missing??
Bye,

Alex


Return to posts index

Brian JonesRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 1, 2013 at 11:53:32 pm

what version of C4D? it seems to be working as expected in 15


Return to posts index

Alex ZetaRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 7:43:10 am

Hi,
It's r14..
Alex


Return to posts index


Brian JonesRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 4:00:05 pm

I'm seeing strange behaviour, if I make it in 14 I get this



if I make it in 15 I get this



If I open the one from 14 in 15 I get the same extra hairs in the centre. You might be too but I'm only seeing them since I am using a transparent cube. Either way if I move the cube the hair is gone where it should be. Something else must be affecting it, can you post the file?


Return to posts index

Adam TrachtenbergRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 4:14:16 pm

It's working fine here in R14 & R15.


Return to posts index

Alex ZetaRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 5:04:24 pm

Hi Brian,
I will able to post the file in a few days.. and did you try to move the plane (not the cube) to see if hair behave correctly?


Return to posts index


Brian JonesRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 7:03:35 pm

Ah, you are right I have been moving the cube, when I move the plane I see the same as you, so far I don't see a way to break that.


Return to posts index

Brian JonesRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 2, 2013 at 7:20:02 pm

even if I clear the AO from the Density channel apply another effect/surface then put AO back in it still retains the original AO...


Return to posts index

Alex ZetaRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 3, 2013 at 6:19:31 pm

Hi,
yes... it seems the AO map won't refresh..
Did it work in R15?

By the way, I'm attaching the file..
Alex


Return to posts index


Brian JonesRe: Strange Behaviour - Ambient Occlusion On Hair Material Channel
by on Nov 3, 2013 at 9:45:46 pm

it did not work in 15, it appears the hair material stores the channels like density and length internally, just guessing but I think when they were developing hair it made sense to lock them so your hair 'styling' didn't move around. I just tried with a noise in World space and that gets locked too and moves with the plane instead of staying locked to world space. Don't know a way around it, same thing happens in the Length channel


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]