MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Xrefs not updating

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Paul RoperXrefs not updating
by on Aug 21, 2013 at 9:02:49 am

I have been having a nightmare with Xrefs and wondered if anyone knows of a solution. My situation:

1. Create a model, let's call it model A. It's a loudspeaker, with no animation and only some basic materials (no image textures).
2. Create a new scene...'scene B'.
3. Go: Create > Xref > Add Xref...
4. Select my model A.
5. In it comes....super. I move it into position. No scaling, no texture editing, no animation, nothing.
6. Open model A (the speaker) again, modify it, then save it.
7. Go to 'scene B', do a Create > Xref > Reload Xrefs.
8. Nothing happens. My loudspeaker (model A) is still exactly the same as it was before I modified it.

I've tried this numerous times, including making the Xref a "generator", and also doing a Create > XRef > XRef and then adding the file in the Attributes window. The file size of the 'scene B' grows considerably, as Cinema 4D has obviously copied the model A into the scene, and is not actually referencing it at all. Basically it's done a "merge". Is there some way I can force C4D to behave as it should? Or are Xrefs just completely rubbish and designed to waste peoples' time and cause immense frustration?

I really need to have a bunch of these models, all the same, in different scenes and do not want to have to do a whole series of copying/pasting/merging if and when any changes happen to those source models. Unfortunately the project has gone too far for me to abandon it and switch to Maya, which handles referenced files exactly as you'd expect.

Any help or suggestions (or even just some sympathy!) would be GREATLY appreciated!



Return to posts index

Cassius MarquesRe: Xrefs not updating
by on Aug 21, 2013 at 12:47:23 pm

All I can think of is if you have the latest updates?

I've had some trouble with xRefs before but that reloading function worked. My problem were with some dynamics being off time on some workstations.

Have you tried going to the tag/layer and hitting the update there? instead of the menu function?

Return to posts index

Adam TrachtenbergRe: Xrefs not updating
by on Aug 21, 2013 at 2:24:49 pm

Is the model you're referencing located on an SSD drive? I've found that Xrefs are definitely wonky when the referenced file is saved on an SSD. If possible try moving the file to a mechanical HD.

Return to posts index

Paul RoperRe: Xrefs not updating
by on Aug 21, 2013 at 2:36:58 pm

Funny you should mention an SSD - I was wondering about moving the XRefs onto one to try to speed things up (C4D is SLOW!), but I won't.

My whole XRef setup is as simple as can be - I haven't moved any of them or changed any of the folder structure since I started the project, there are no duplicated files, the only animation I'm doing in the entire project is camera moves, and the models only have very basic materials. And the project has only ever been on this one machine. The only remaining options are user error or C4D sucks. In terms of user error, I've been inserting an XRef, then editing that source file, then trying to update the XRef. Not really much scope for error there.

I should never have left the wonderful world of Maya.

Return to posts index

Brian JonesRe: Xrefs not updating
by on Aug 21, 2013 at 3:00:17 pm

I have found xrefs to be painfully slow and don't use them myself - I use a reference object in the scene and then just make Instances of that.

Return to posts index

Adam TrachtenbergRe: Xrefs not updating
by on Aug 21, 2013 at 3:04:13 pm

What version of C4D are you using? I'm on R14 and have no problem updating Xrefs unless the reference file is on an SSD.

Return to posts index

Paul RoperRe: Xrefs not updating
by on Aug 21, 2013 at 3:19:54 pm

I'm on R14 too. R14.042

This afternoon it's been behaving slightly better (as long as I make everything a "generator"). But after I bring in a new XRef object, and click "generator", it asks me where each and every other XRef is. I can just click "no" each time the stupid dialog box asks me to select a new file path for each object, most of the time.

I did (foolishly) copy the project to another machine (another Mac, same spec, same C4D R14) so I could use it for rendering, but of course it flatly refused to 'see' any of the XRefs, even if I reloaded them or updated the file paths. C4D didn't say it couldn't find them - C4D thought everything was fine, and my scene was supposed to be almost empty. So I have access to a second nice high-end Mac Pro, just sitting there waiting to churn through renders. But no, C4D refuses to co-operate. Thank you once again, Maxon.

Return to posts index

Paul RoperRe: Xrefs not updating
by on Aug 21, 2013 at 4:31:24 pm

Also, is it normal that the Xref manager does absolutely nothing whatsoever? The mysterious and unlabelled check-boxes to the right of each Xref do nothing, as does selecting "Exchange...".

If I choose a new XRef in the attributes manager (I want to change the XRef to something else), as predicted, absolutely f**k all happens.

What a great piece of software.

Return to posts index

Adam TrachtenbergRe: Xrefs not updating
by on Aug 21, 2013 at 10:55:47 pm

Not an excuse, but Xrefs are relatively new to Cinema and they obviously need more work.

That said ... have you read the help file on this topic? Exchange switches out references for reference proxies if you've assigned them (you have to be using encapsulated xrefs for this to work). The check boxes in the manager load an unload xrefs or selected parts of them. Seems to work differently depending on whether you're using encapsulated or not.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved