MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Problem With Bend Deformers For Rig Of Leather Book Cover

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike TosettoProblem With Bend Deformers For Rig Of Leather Book Cover
by on Feb 27, 2013 at 12:32:45 am

Hi

A friend helped me rig this leather book cover using bend deformers. I'm stoked with the rig as it does exactly what I need it to do.

Although I'm having some deformation problems that I just can't work out.

I've included the C4D file along with a screen grab that shows the problem. Downloadable here:
https://dl.dropbox.com/u/26831058/LeatherCover.zip

The rig is set up to be controlled via the Null called 'MoleSkine Cover'. If you look at the file in the top view and scrub through the first 45 frames you'll see the problem at 34-42 frames. You'll also clearly see the problem in the screen grabs included in the ZIP file.

If anybody could please just run their eyes over the file and see if you can see the problem, that would be awesome.

The deformation problem happens on one side but not the other so it leads me to believe it has something to do with the order in which C4D calculates the animation.

Thanks

Mike

miketosetto dot com | bestiacollective dot com


Return to posts index

Adam TrachtenbergRe: Problem With Bend Deformers For Rig Of Leather Book Cover
by on Feb 27, 2013 at 4:27:26 am

Looks like the cover bend deformers are conflicting where they cross over the geometry that's been deformed by the cover close deformers. I think you're going to have to split up that geometry to avoid it.


Return to posts index

Mike TosettoRe: Problem With Bend Deformers For Rig Of Leather Book Cover
by on Feb 27, 2013 at 4:32:36 am

Hi Adam, thanks for getting back to me.

What's really strange is that it doesn't happen on the other side.

What's even stranger is that if I put 'Front_Cover_Bend' on top of 'Back_Cover_Bend', then the problem happens on the opposite side.

The fact that the conflict happens only on one side, and that side it happens on can be changed by placing one bend deformer on top of the other, makes me think it must be fixable...

I just don't know how to fix it. Like I mentioned, my friend helped me rig it and everything works great except for this, which I'm hoping is just a hurdle.

Mike

miketosetto dot com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]