MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Spline Wrap lagging behind the spline.(PhoneCord)

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Marius JerschkeSpline Wrap lagging behind the spline.(PhoneCord)
by on Jan 11, 2013 at 11:12:58 am

Hello COWs,

I watched several phone cord tutorials and some more... I work over 3 weeks on my damn phone cord now... but the spline wrap always laggs behind the spline.....


perhaps you have a specific idea to emulate the spline wrap in xpresso... or so....

components:

-Spline(20 Vertex)
-Sweep Nurb(Helix & N-Gon)
-Spline Wrap

-Hair-Dynamics: Spline-Dynamics-Tag; Constraint-Tag; Hair-Collision-
Tag



greets

and thanks for your great help


Return to posts index

Adam TrachtenbergRe: Spline Wrap lagging behind the spline.(PhoneCord)
by on Jan 11, 2013 at 5:27:16 pm

This is an order of execution problem which crops up from time to time. You have to understand that there are two factors that affect the order in which things are executed by Cinema:

1. The stacking order of objects in the Object Manager; and
2. The priorities assigned to classes of objects and to tags (which can be changed in the tags' Basic tab.

In this case I think you can fix the problem by moving the spline wrap deformer below the dynamic spline in the Object Manager. I'm not talking about heirarchy, but it just has to be lower than the spline in the object list. That's because objects at the top of the list are evaluated before objects lower in the list. Since the spline wrap deformer has to evaluate the position of the spline, the spline movement has to happen first.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]