MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Cinema 4D - After effects object buffer not allighing with screen

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Wagstaff
Cinema 4D - After effects object buffer not allighing with screen
on Oct 4, 2012 at 11:46:15 am

I am working on a scene that has a lot of video screens and when i try to use the object buffer method this is what happens



I have a composting tag with an object buffer for both screens as well as an external tag with the size set to the screen and set to solid

What am i doing wrong that makes the buffer solid not align with the screen

Any help would be great

Andrew


Return to posts index

Kevin Camin
Re: Cinema 4D - After effects object buffer not allighing with screen
on Oct 5, 2012 at 5:16:47 pm

Just had this problem.

Of course you can rotate your 3D nulls into position in AE, but I bet when you do that there will be drift; your 3D null won't stay where it should and your image will slide around.

I think there is a bug in C4D. You need to align your planes to a +Z orientation in the parameter settings. Then you can rotate them into whatever orientation you need. This should fix everything.

Best regards,

Kevin Camin


Return to posts index

Darby Edelen
Re: Cinema 4D - After effects object buffer not allighing with screen
on Oct 5, 2012 at 7:35:40 pm

[Kevin Camin] "I think there is a bug in C4D. You need to align your planes to a +Z orientation in the parameter settings. Then you can rotate them into whatever orientation you need. This should fix everything."

It's been a while since I've used the External Compositing tag, but I believe Kevin is right.

Essentially AE will only see the Axis data of the object that you've applied the External Compositing tag to. Since solids in After Effects always face down their Z-axis Kevin's suggestion for using a Z+ orientation will work for primitive planes.

If you're working with a polygon object you'll want to rotate the Axis (Enable Axis modification, then use the rotate tool) to match the orientation that After Effects will force on the imported solid/null.

As a fix for your current setup in After Effecs you can duplicate the solids that AE imported, parent the duplicates to the original imports, remove all keyframes from the duplicates and then rotate them 90° on either the X or Y axis (the axis you need to rotate on may vary). Hopefully that will work :)

Darby Edelen


Return to posts index


Andrew Wagstaff
Re: Cinema 4D - After effects object buffer not allighing with screen
on Oct 8, 2012 at 9:14:37 pm

Thanks guys i got it sorted

all i had to do was rotate the H rotation of the objects to 0 for some reason it was set to -90


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]