MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

Containing objects within another via rigid and collider

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Craig RickerContaining objects within another via rigid and collider
by on Apr 13, 2012 at 6:21:38 am

Hi there,

I have made a raffle barrel, and i'd like to put some tokens inside that I will animate getting pulled out.
I only have Cinema 4d broadcast, and so I can only do dynamics inside a mograph object.

So i'm using a mograph cloner to create 6 tokens.

When i spin the barrel, the tokens do interact with the barrel and bounce around inside, but some of them go flying out of it? The faster I spin the barrel, the quicker majority of them fly out.

Is there some settings that allows them to get past a collider object?


Return to posts index

Craig RickerRe: Containing objects within another via rigid and collider
by on Apr 13, 2012 at 6:23:37 am

3976_barrel.c4d.zip

Here is the scene file if you'd like to see.


Return to posts index

randy johnsonRe: Containing objects within another via rigid and collider
by on Apr 13, 2012 at 8:15:51 am

Your papers are flying out between the frames.... the faster you go the more stuff happens between the frames so they find holes faster.
Solution:
In your Project settings (cmd or ctrl) D.
The Dynamics : expert tab you can change the Steps per frame try some higher settings.
With your animation now 10 works but if you change some settings you may need more.

As this project is you don't need to change it, but sometimes you get a similar issue from using the wrong solver shape... on your rigid body tag Collision:Shape is set to Auto, generally Moving mesh is the answer.

/Randy


Return to posts index


Craig RickerRe: Containing objects within another via rigid and collider
by on Apr 15, 2012 at 11:38:50 pm

BRILLIANT! thankyou!

Ok I now have a stupid issue with a null. The lock on the front of the barrel, I would like to rotate to unlock. The polygon objects that make up the lock are in a null, and the rotation bands of the null are not in the right axis, i.e not lying in the way I would like to make a rotation.

I've tried everything i'm aware of to attempt to change the angle of these bands using the enable axis modification tool. I cant seem to change them though?

What am I missing?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]