MAXON CINEMA 4D: Cinema 4D Forum Adobe After Effects Forum

C4D Luminance Not Emitting Light

COW Forums : Maxon Cinema 4D

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Robert Uther
C4D Luminance Not Emitting Light
on Feb 3, 2012 at 7:06:46 am

I have an object that has many different textures attached to it. There's one specific texture I want to have a luminance channel, but it doesn't emit light onto the scene. I Googled the problem but to no avail. Help?


Return to posts index

Brian Jones
Re: C4D Luminance Not Emitting Light
on Feb 3, 2012 at 5:18:36 pm

for Luminance to extra illumination you need to use Global Illumination


Return to posts index

Robert Uther
Re: C4D Luminance Not Emitting Light
on Feb 3, 2012 at 11:15:46 pm

Thanks for your help, but I do have GI on. Even then, it doesn't show any light.


Return to posts index


Brian Jones
Re: C4D Luminance Not Emitting Light
on Feb 4, 2012 at 1:35:20 am

if you have lights in the scene (not lit by HDRI) it's fairly easy to overwhelm the GI particularly if the luminance is not pretty strong (100%). You can crank up the GI in that case - which could make everything way too bright but you can control what generates/receives GI. It's also possible to turn off GI for the luminant material in the Material Tag but I assume you have not done that.


Return to posts index

Robert Uther
Re: C4D Luminance Not Emitting Light
on Feb 4, 2012 at 5:18:27 am

I finally figured it out: it was Ambient Occlusion that was darkening the lights. I'm not sure how, but it was. Would you mind helping me with another problem? I add a luminance channel to a texture but I also want it to retain that texture. I don't want it to become washed out or too bright. I want it to look as if it doesn't have a luminance channel but is actually emitting light. Do you kinda get what I mean?


Return to posts index

Brian Jones
Re: C4D Luminance Not Emitting Light
on Feb 4, 2012 at 7:02:34 am

if you put the same texture in Luminance as is in Color it will light the scene but still look like the texture - you lose shadowing on the object though. Do you need that?


Return to posts index


Robert Uther
Re: C4D Luminance Not Emitting Light
on Feb 4, 2012 at 5:51:23 pm

Thanks, it worked! But I have to really crank up the GI illumination settings and luminance intensity. Because of this, the textures close to the light become completely white while other objects of medium distance away look fine. I noticed C4D lights don't have this issue, but with the number of lights I require in the scene, I can't possibly put down so many lights. The only easy way I can do it is through texture channels like luminance or glow.

Sorry for all the questions. I'm still just a beginner.


Return to posts index

Brian Jones
Re: C4D Luminance Not Emitting Light
on Feb 4, 2012 at 8:43:30 pm

you have a couple possibilities, you can fake it and don't use GI just use a light inside the object (with the same texture (luminance channel) on it if you need the colours to match) with no shadow so it shines through the object - or you can use GI at normal levels and control the amount for various objects by putting a Compositing tag on the object that *receives* the GI from your glowing object and in the GI tab increase the Intensity Ratio. That will likely make that object (or objects) too bright still but you can have only your glowing object make any GI by going into all the other textures and in the Illumination tab turn off Generate GI, not a real problem you can select all the textures at once and change the setting for all of them with one click. - You can also do the same thing in the Illumination tab of your textures by controlling the amounts under Generate and Receive GI with out using a Compositing tag.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]